Can't edit Numbers spreadsheets stored in DT3

I have several Numbers spreadsheets stored in DT3 but can’t edit them.
Am I missing something?
I tried Tools>Sheets>New Record but it’s greyed out as this is a .numbers file not a .sheets file.

My reading leads me to believe that I should be able to work with Numbers files stored in DT3, so maybe there is a Preference or Service I need to enable. Is it best practice to index them in DT3 and leave the files outside the db?

Have you tried right-clicking on the file in DT3 and choosing “Open With”?

If you right-click on a similar file in Finder and choose Get Info, is the default opening app set to Numbers?

1 Like

O, you are so right! (head-slam)
Thank you x 10^9

I right-click on a Numbers spreadsheet. Select open with Numbers.
I edit the spreadsheet in Numbers. When I close the spreadsheet Numbers asks me to save the spreadsheet. If I select save, a new copy of the spreadsheet is created not linked to DT3. I don’t want to save a new spreadsheet. If I select cancel no changes are saved…

BTW, I am on Monterey Beta (21A5552a)

Are you choosing “Save As” or “Save”?

FYI, here’s what I see on MacOS 11.6, Numbers 11.2, and DEVONthink 3.8 …

  • Drag a fresh Numbers spreadsheet into a DEVONthink Group in my Works in Progress database. I confirm I am working with a Numbers file in DEVONthink and not one still in the file system.
  • “Open With … Numbers” that file as I point to it with mouse inside DEVONthink.
  • Make a change. In Numbers Menu File → Close, and the file is saved back into DEVONthink. Numbers does not ask permission to save. File saved back to DEVONthink with changes.
  • Numbers spreadsheet is then nicely displayed in the DEVONthink window

If I do a “Open With … Numbers” again, then make changes, and say Numbers Menu → Save, the sheet stays open and a new version stored in DEVONthink. Same with Command-S save key.

So, I’m not seeing what you report. I’m not running any beta software.

I’ve been exercising Numbers recently to see if I can drop my Office 365 license in January when it’s up for renewal. So far I conclude I can.

As long as you don’t use any excel macros…

Nope. I find ways other than Excel macros to feed my programming fix. :wink:

The key USP for Excel for so long was Pivot Tables. Numbers now has them. Not QUITE as good as Excel (missing groups, and a few functions not there, but have found work-arounds), but good enough. Otherwise for me full-featured. License fee is attractive.

1 Like

This seems to be working for me!

Thanks everyone!

1 Like

Welcome @montymo and glad to hear it! :slight_smile: