Can't edit or change databases

I just got a new fast boot drive and installed a fresh copy of OS X and all applications, including DTPO.

My databases are stored on a separate internal volume (Mac Pro) called Data.

When I opened these databases, they appeared with a crossed-out pencil, which appears to be a “read-only” icon. I can’t edit or change the databases in any way.

My old boot drive with my old user account is still inside my Mac Pro. Is this why the databases are “read-only”? Do they “belong” to my other user account? If so, how do I change that?

I would close all open databases from within DtPO (menu bar > File > close database), then quit DtPO and check the permissions for each database in the Finder’s info panel (mark the database in the Finder and do a CMD + i).
Permissions should look like this:
Please also check this too for the volume (hard disk) on which the databases are stored. Preferably you want to move the databases out of the old user account into your new one, to not conflict with permissions again and have the files where they belong. If you do so, check permissions afterwards.

Then start DtPO and open the databases anew from the menu bar > File > ‘open database’. Make sure you open the ones from the correct location.

Thanks. Just to clarify, the databases aren’t stored in the old user account. They are on a separate volume where I store my data. Would your advice here still apply?

Yes, check permissions for the volume and each database. Maybe you have to unlock the lock in the lower right corner to be able to make changes and if you change the permissions for the hard drive, you maybe want to choose “apply to enclosed items” from the action menu in that window - given you want to have read+write permissions to all files on that volume.

This might be a question for the Apple forums, but when I attempt to add myself in the permissions dialog and change to “read & write”, I can’t. It will only allow “read only”.

Read & write is actually selectable in the pop-up menu, but when I select it, nothing happens. It simply reverts to read-only.

Any ideas?

You may need to add your username to the list of those with access, then give yourself read & write access.

I cannot check as I’m iPhone-only at the moment, but first there is that little lock in the lower right corner of the Finder’s info panel that you will need to unlock to make changes. And in the lower left corner there should be an option called “ignore ownership on this volume” - maybe you have checkmark this to apply changes.

Thanks. I ended up using a Terminal command to change permissions on the entire volume. It’s working now.