Can't get one RSS feed to work - any ideas?

Trying to use DT Pro as a news reader as will be clipping articles from various blogs and like of idea of keeping it all together.

All working fine with several blogs but one, and one only, doesn’t seem to load. I can get it to work in another news reader but it won’t load any articles in DT and I’m at a loss to understand why or what I can do.

The blog is:
and the RSS feed (though there are alternatives) is:

Have tried umpteen different ways of doing it but nothing works.

Any ideas?

This feed is working fine over here after (!) locking & refreshing it. Why? By default news are removed after one week over here and the newest item in this feed is older than one week. You could also increase the limit or remove articles manually instead of locking (see Preferences > RSS).

I’m probably doing something daft but I’ve tried marking it as lock and refreshing.Nothing happens. Still no entries appear.

I’ve adjusted Feed preferences (I had it set to delete manually but changed to one month). Didn’t make any difference. It recognises the name of the blog feed but no posts come up at all.

Is this what you put into the feed?


Again I’ve tried variants.

I’m sure I’m ignoring something very simple but it’s driving me slightly bananas.

Exactly (via Data > New > Feed…). Afterwards I’ve just locked the feed and refreshed it (via the contextual menu) and 25 items appear.

That’s exactly what I did and NOTHING appeared. Yet other blogs working perfectly.

Have to go out now. Will restart and try again tonight and see if makes any difference. Not the most important thing in the world. Just irritating that i can’t make it work.

Nope. I’ve tried everything you suggest again and again. The feed title adjusts properly into separate words, which I imagine means it is “seeing it” but I cannot get it to load any of the posts.

I think I’ll just need to give up and consider it a mystery to rank with the Marie Celeste and Roswell.