Can't get "previews" of many PDFs anymor


Last night I quit DevonThink and then put the machine to sleep.  Problem was, DevonThink was taking its own sweet time doing some optimizing, and after 30 seconds when I slept the machine, DevonThink was still chugging along.  So effectively I shut it down in the middle of the optimization (oops, I noticed after I hit sleep and uttered some bad words :wink:  This morning I had to force quit DevonThink because it hung when I slept the machine.

At any rate, this morning, now all PDFs show up as a “PDF” icon, rather than a preview.  I did a database repair earlier and saw something like “20,000 in memory errors.”  To try and regain the previews, I did a database rebuild (which exports and re-imports), and it worked for SOME of the icons, but not all of them.  Also, a few of my files were lost from the database (they’re still in the “files” folder, but I had to re-drag them to DevonThink), so it appears I’ve done a decent “oops” :stuck_out_tongue:

Maybe I’ll restore from a backup… any other way to regain the preview information?


Using "Force quit" probably truncated the files and therefore some PDF documents copied into (!) the database and/or thumbnails are missing. Using the backup (see folder ~/Library/Application Support/DEVONthink/Backup) might solve the problem. In addition, the upcoming release 1.9 will make such troubles much more unlikely (due to a revised "Backup & Optimize" command and by forcing OS X to flush its caches immediately).

Yeah, I tried a couple times to fix things, to no avail.  I run ChronoSync a couple times daily, and it backs up the database, so I just restored from backup and lost no data.

I’ll try and be more careful next time, tho’