Can't make direct connection MBP to iMac, but can other way

I tried making a direct connection from DTPO on my iMac to DTPO on my MBP and it worked. Huzzah.

But I can’t do it the other way round, from my MBP to my iMac - it tries but always fails with an error saying it was unable. Boo.

Any idea why this should be ?

The error is what?

Are you System Preferences > Sharing the same on each machine?

The error is, when I click “Sync Now” on the MBP, the Activity panel starts, and appears to make some progress, but stops halfway (for ages), and then the log panel comes up with “Could not open the connection (The operation couldn’t be completed. Operation timed out)”.

Yes, both machines have file sharing on. Apple file sharing works fine both ways between them.

Also, firewall is off on both machines.

I think I found out what was wrong. One machine, the iMac, was connected to the network by way of a physical ethernet connection to the router, whilst the other was connected via Wi-Fi.

Despite the fact that the iMac was connected to the network via ethernet, I had to turn its Wi-Fi on and make sure it was connected to the network via Wi-Fi before it would sync.

Thanks for the report back.