Can't print PDF to DTPO

I just updated to DTPO 1.3.1, and find that no longer can I hit “print” --> “save to DEVONThink Pro.scpt” and save a PDF of the website in my DTPO database. Under 1.3, I would follow those commands, get a print progress bar, then have DTPO come up so I could assign the PDF to the proper folder. Now, with 1.3.1, I get the print progress bar then nothing more. No PDF saved to my DTPO database, nuthin’. Any ideas? Thanks.

Dale Keiger

Hi, Dale. No problem here using the “Save to DEVONthink Pro.scpt” routine to print PDFs to my database.

Do you get a Log report or seen anything in Console related to the failure?

Do you perhaps have a haxie installed? ShapeShifter especially causes problems with PDFs.

Have you run the Disk Utility permissions repair routine on your hard drive recently? I recommend doing that before and after any Apple updates.

When I try to print out of Firefox, I see the print progress bar, then nothing more happens. Nothing shows up in the console log report.

When I try to print to DTPO out of Safari, I get an error message–“error while printing” (not exactly helpful)–and this on the console:

2007-03-12 12:00:26.638 Safari[552] PMSessionEndDocumentNoDialog failed (error code = -10814)

I am running OS 10.3.9. I had been running ShapeShifter but disabled it and rebooted, to no effect. I have run disk repair, and applejack. At home, running 10.4.xx, I’m having no problems. And I had no problems running DTPO 1.3; the problems began with 1.3.1.

Hope this helps, Thanks.

Dale, do you still have APE and any other haxies on the computer that can’t print PDFs to your database? You may need to uninstall the lot.

A cautionary note:

DT Pro makes very heavy use of the Mac technologies built into OS X. DT Pro has a great many commands and routines that make calls to the operating system – many more than the ‘average bear’ Mac application.

If OS X code that’s called by DT Pro has been altered or damaged, problems will result.

But there are a great many applications and utilities out there that deliberately modify the operating system, including haxies and some input managers. Some of them are toys, like ShapeShifter, which changes the appearance of OS X. Others modify or add-on features to the operating system. The problem is that all too often there are unintended consequences that result in memory errors or even in breaking portions of the operating system. When that happens, routines called by DT Pro can fail, or errors can occur and cascade, or data may be corrupted.

My practice is to avoid installing anything on my computer that modifies the operation system, unless I’ve got an essential reason for doing so and I’ve thoroughly checked it out to be sure that it’s not going to cause problems. I avoid haxies and third-party input managers like the plague.

And I do routine preventive maintenance of my operating system and disk directory, to keep them in good shape. I don’t have damaged fonts. I clean out old caches fairly often, to minimize problems that could result from damaged caches.

As a result, I don’t have stability problems with my databases. I haven’t had to resort to a backup in more than two years. When I run Verify & Repair I don’t see error reports. I don’t lose data, and DT Pro “just works”. But I religiously make backups, anyway.

So, is DT Pro more “sensitive” to altered or damaged code in the operating system than most Mac applications? Only in the sense that it makes more calls to OS X technologies than, for example, a word processor or spreadsheet program is likely to make – but other programs can be affected, too.

Moral: try not to monkey with your operating system; keep it clean. Apple probably engineered the operating system code the way it is for good reasons. They’ve got procedures for testing OS modifications that far exceed the capabilities of most third-party developers, including extensive internal and external beta tests.

Bill,

Thank you for the detailed response. I’ve disabled APE and will see what that accomplishes. I had no problem at all running APE, ShapeShifter, and LabelsX with DTPO 1.3. Did something change with 1.3.1, or is the onset of my problems coincidental with upgrading DTPO?

Dale

No, memory errors caused by ShapeShifter and other OS modifications have been common in earlier versions of DT Pro and DT Pro Office, as reported by other users, especially the PDF problems.

Memory errors are often cumulative, flaky and unpredictable. You simply encountered them recently.

Well, I’ve disabled all of that stuff, and it hasn’t helped.

Stumped in Baltimore

I’m having the same problem Dale is. I’m attempting to save a Powerpoint file as a PDF file to DTpro. In Powerpoint, this means that the script appears on the PDF submenu within the Print dialogue.

So I do that, and the script grinds away, showing a progress bar, then returns the error message:
“The variable this_name is not defined.”

Looking at the code, the problem seems to be in this block:

tell application this_app
				try
					set this_name to the name of window 1
				on error
					set this_name to ""
				end try
				
				repeat while this_name is ""
					display dialog "Saving to DEVONthink Pro. Please enter a file name:" default answer this_name
					set this_name to the text returned of the result
				end repeat
			end tell

However, the dialog box asking for a file name never appears, I just get the error message. Saving to a PDF file using this menu works fine.

The following appears in the console.log file as soon as I invoke Powerpoint’s Print command and before I actually invoke the DTP script:

2007-03-13 15:41:01.165 Microsoft PowerPoint[1451] CFLog (22): Cannot find function pointer PowerPointPluginFactory for factory 6E2BC746-EE80-11D4-85E8-0030656AFD76 in CFBundle/CFPlugIn 0x116d10d0 </Applications/Microsoft Office 2004/Office/PowerPointPrintError in packet
Reason: (noSuchName) There is no such variable name in this MIB.
PDE.plugin> (bundle, loaded)
Error in packet
Reason: (noSuchName) There is no such variable name in this MIB.

There are no haxies on the system, I run maintenance regularly, and it exhibits no other signs of instability.

I would blame PowerPoint for failing to handle scripts correctly, except I vaguely remember that someone here suggested exactly this procedure as a way to get Powerpoint files into DT.

Any suggestions?

Katherine