Can't save edited files

I’ve been using osx devonthink for many years, I’ve recently purchased an ipad so upgraded my DTTG from the older version (which I synched to my phone) to the current version.

Most of my notes are RTF or RTFD and were imported from Devonthink on my Mac.

If I try to edit a note, I push the edit button, make my changes, then push the circled x at the top R.
It appears to be saved, but if I go off that note to another, then return, my changes are not saved.

What am I missing? surely it can’t be too hard to save editing changes, I lost a whole days work thinking the changes would be saved.

Which version of DTTG are you using?


The current version is 3.5.4, and fixed a bug in the editor which was introduced in 3.5.3 which led to edits being lost.

There was a thread on the topic, and the update was issued at the beginning of August. The thread only mentions Markdown, but I’ll wager a bet your problem is the same. Perhaps update to the current version and check.

Thanks, that seems to have worked, its the first time I’ve tried to edit a note, usually I do everything on my macbook. My auto updates are turned on, strange it didn’t update.

Indeed, it was related.