can't use Services keyboard shortcut

I’ve discovered that under Safari’s Services menu the DT section has keyboard shortcuts for take plain note and take rich note, but when I use them it doesn’t work. Can someone explain that? Thanks.


Make sure that you have SELECTED a portion of text in the Safari window before you go to the Services menu and Append or Take the Plain/Rich note. If that still does not work for you, then I am baffled!

Wait…here we go…I had to hold down Shift and CMD and press (

The services menu only lists CMD - (

Yep. That’s 'cuz you have to shift to create ( or ).

hahhahahaha…oh boy, i’m an idiot…

Nawww you’re not. I think that being so immersed in work, new software, etc., causes us all to get a little bit dazed from time to time.


Any plans to add these keyboard shortcuts to DevonNote? I clip stuff from the web all the time and would love to be able to do so via keyboard rather than menus, but I don’t see any shortcuts noted next to the “take” and “append” commands in DN.

You might want to try a freeware preference pane from Blacktree Software called “Service Manager.” It gives you complete control of services and their hotkeys. It can be downloaded at

I have been using it for a couple of years now, and it has worked from OS X 10.x to the latest and greatest version of Panther. It IS beta software, but has worked without a hiccup for me all this time.

When launched it from the System Preferences pane it…

  1. Gathers info on all the apps that have services from EVERYWHERE. This takes a minute, especially if you have a backup drive online etc. Hint: dismount these first. If you don’t it will show dupes of any app and its preferences it can find. So if you have DEVONWhatever on both your main and backup drives it will show both. If you tried out an app and deleted it, but not its preferences, it will be there too. Unfortunately, when it finds multiple identical apps Service Manager doesn’t show which app is located where. This is the ONLY fault I can find with it. But hey, it’s free!

  2. You can eliminate any or all services from any app entirely with a simple checkbox. With all the services unchecked, the app will not show in Services at all. With only some services unchecked, those services will not appear but the app’s other services still checked will still be present.

  3. You can remove the hotkey for any app and still have its services appear. It just has to be manually selected.

  4. You can change or add hotkeys to any app on the list. You can have one set of hotkeys for DT Pro and a similar but different one for DTPE. Whatever you want.

  5. You can put everything back to default by pressing one button.

Therefore…you have complete control of your services and their hotkeys. A side benefit is that you will be amazed how many apps use the SAME shortcut keys, which can and does play havoc. For example, both GuzzleWit and ThingWhazzit may use cmd-shift-x to do their thing. As you may expect, the results of using this key combination is a crap shoot. Both DT versions having the same service keys might be the reason nothing happens when you have both DT versions installed.

THE INEVITABLE DISCLAIMER: I have used the Service Manager preference pane with success for quite a while. Your mileage may vary. If it eats your hard drive, causes sterility or causes your Prius to get the gas mileage of a Hummer, I will not be responsible. The URL above recommends you back up your preferences first, and I do too.

I hope this will help!


I also use this “servicemanagerprefpane” beta without any problems. Alternatively you could manually edit the NSServices and NSKeyEquivalent entrys of an applications info.plist file using the “Property List Editor”.


You’re right of course, Louise. But
A) I’m the world’s third laziest person. If I can find a program that does something for me and I don’t have to move too much, I go for it.
B) Terms like “NSServices” make my brain hurt.

All yucks aside, I have messed around with the NS thingies using Property List Editor, but Service Manager has it all in one place. The thing I value MOST about it is the control it provides of the Services pulldown. I can eliminate the services I never use, which makes it faster.

And, as important to me, it helps maintain control over the hotkeys across my entire system. I use Menu Master to help tame individual programs. I have used IKey as well, but not since switching to Panther.


I made the mistake of installing Devonthink pro before uninstalling Devonthink since I thought it would replace the previous software. I dragged Devonthink afterwards to the trash but now I can’t get the services key shortcuts to work in Devonthink Pro.

I first noticed that Hogs Bay notebook stole the services shortcut when I removed Devonthink but I edited the plist for that application to deactivate the services key so it could be used by Devonthink pro. No luck.

I tried re-entering the key in Devonthink pro plist but no luck.

I tried the services manager suggested on this forum (thank you very much) and found that it identified Devonthink as still using the keys too (leading me to believe that Devonthink wasn’t properly uninstalled). I deactivated the keys in Devonthink using services manager but still no luck.

Each time I have logged out and logged back in but that hasn’t helped activate the Devonthink pro services keys.

Any suggestions on how to fix this? I know I could implement some workarounds using scripts to possibly replicate what the servies shortcut keys do but I would prefer to fix the problem since I have heard that corrupt preferences can cause other problems.

Thanks for any suggestions you might have as it really bothers me when my Mac is not working as it should. :cry: :frowning: