Can't view online PDF anymore

Actually it is possible to add links to the download manager via drag & drop. Or just Option-click the link.

Anyway, the PDF document is viewable over here (Safari 5.0.2, Mac OS X 10.6.4, no third-party extensions). Did you disable JavaScript/plugins? Or did you install the Adobe Reader Internet plugin? But…

…actually this sounds like a network issue as the WebKit display, the AppleScript support and the download manager don’t have much in common. Do you use LittleSnitch?

Oops… I’ve edited your posting instead of quoting it. My fault… I’m sorry :blush:

Yeah, I figured there was something particular to my config because this was working for me several days ago. I probably do have the Adobe Reader plug-in installed, but I have it disabled. Safari shows PDFs in its native viewer. I don’t have Little Snitch, but I could get it. What do you want me to log with it?

That’s really weird that drag-n-drop for the Download Manager window not working for me. (I am dragging a link from DT, not Finder or Safari.) I’ll try it again and see if I can figure out what I’m doing wrong.


You could check whether anything has been logged to the system console (/Applications/Utilities/ and whether disabling plugins (see Preferences > Web) will fix this.

What exactly did you drag from where and where did you try to drop it?

Nothing in the Console. The first time after enabling plugins, I get a file dialog saying it can’t find Adobe plugin. (Sorry I didn’t remember that from before. It will only do it once, after which it just stalls with the loading. With all the things I was trying, I forgot that had happened by the time I wrote the post.) How do I make DT use the native PDF viewer like Safari instead of trying to use Adobe’s? And why would this have any affect on the script “create PDF Document from”? Thanks.

This is working for me now. I was dragging a bookmark from the list view in the Three Panes view to the Download Manager mini-window. I think what I got confused with is that if the link URL has already been added, it will not let it get added again. But it just “revokes” the drag instead of also indicating it is already in the list.

You can set Apple’s Preview application as the “parent” application of PDFs in the Finder.

Control-Click on any PDF file in the Finder. Choose the contextual menu option, “Get Info”. Choose Preview to open the file in the Info panel. Then choose the option to set Preview to open ALL PDFs.

I already had Preview set to handle all PDFs, but I did it again like you said, and that did the trick. :smiley: In updating Acrobat and/or Reader, I must have broken that. Thanks a bunch. I tested “create PDF document from” as well, and that works again too.