Capturing to PDF in DTP

I’ve owned DevonThink for a long time, and I used it for a long time before the capture workflow and overall interface eventually drove me nuts. I switched to using EagleFiler and then Together. Now with the release of DTP2, I’m working on switching back, primarily for auto-classification. The interface is something I can live with, and capture workflow has improved a bit, probably more-so once the Sorter works fully.

One of the things I did, in switching to some other programs, was to start capturing webpages as PDFs (with working hyperlinks) instead of webarchives. In the switchover process, I realized that a lot of my older webarchives weren’t looking right/missing images, etc. If I tried to reload from the original page, it was offline/taken down/redesigned, etc. So if I wanted a true representation of the page frozen in time, then the PDF was the way to go. And it works great!

But I’m still having troubles getting a great workflow capturing PDFs from webpages in DTP2. It seems that the bookmarklet is the only way to do it. I’d like to be able to able to drag to the Sorter and have a PDF created. Alternatively and preferably, I’d like to to have a capture keystroke that captures a PDF to the inbox. I see in the Sorter preference, there is a capture keystroke, but it doesn’t seem to work. In Safari, it types a “c” when I use it and starts searching for “c” on the webpage I’m looking at.

I’m also having issues with PDFs captured with DTP2. They aren’t formatted properly and they get seemingly random names. In Together, they get named with the name of the webpage which is much nicer than “pxg1.pdf” More importantly, they don’t look right. I uploaded examples of a page captured as PDF in both DTP2 and Together.



Please let me know if I’m missing anything and/or consider this feedback for the development of 2.0.

Thanks!

In general, the Hot key capture will only work when you make a selection. Just being on a page doesn’t work. There is nothing we can do about this unless we put our code inside each and every program you are running and that is not a safe thing to do.

Well, I just rebooted and changed my shortcut from opt-11 to opt-12 to command-12. Still doesn’t work, even having made a selection. Safari thinks I’m typing a “c” and tries to search for the letter c on the page. Maybe a problem with Sorter?

With regards to the capture-key code, there must be some way to accomplish it without inserting your code into other apps, because both Eaglefiler and Together work this way without putting their code into other apps. I guess I could deal with DTP2 not working that way if I could get Sorter to capture a page as a proper looking PDF.

John

Regarding the PDFs, here’s another issue I forgot to mention. When capturing as a webarchive, a page such as this:

sparkpeople.com/resource/fit … sp?id=1102

takes about 9-10 seconds to fully render when selecting it in DTP. That same page renders pretty much instantly when captured as a pdf. The resulting capture looks like this in DTP:

and like this when captured in Together as a PDF:

Regarding the other programs’ capture: they use an elaborate mechanism with customised AppleScript that is tailored to each application. We may do that eventually but at the moment we have more than enough on our plate.
It seems that somehow the Command-key aspect gets lost on your end. Are you using any plugins (possibly specific for Safari) that modify key bindings?

I would just like to say that if this is the case, I do understand that Devonthink has loads of other things you need to focus on right now, but it might be a really good idea to perhaps implement a ‘elaborate mechanism with customized AppleScript that is tailored to each application’ for just Safari and PDFs, because the output that Together produces is easily much nicer looking then what Devonthink does. Yes I know it is all Apple’s PDF kit, but really I don’t think anybody cares why it looks better or worse, just that it does.

I have tried Together and find it both slow with larger databases, very unstable at times and nowhere near as many features as Devonthink, but honestly the output Together produces is much nicer looking. Taking a look at the images John uploaded makes this painfully obvious.

If you wish to make a WebArchive capture of a page displayed in Safari, use the command available in Services.

  1. Click on the page in Safari. If you wish to capture the entire page as WebArchive, press Command-A to Select All. If you wish to capture just a portion of the page as WebArchive, select just that portion.

  2. Choose Services > DEVONthink Pro > Capture WebArchive. Keyboard shortcut: Command-%

The capture will be almost instantaneous, as this capture does not require re-downloading the page. However, use of a script will require re-downloading the page.

I didn’t see any artifacts when capturing that page as PDF using the Print as PDF to DEVONthink route, nor as capturing it as 1-page PDF in DEVONagent or in DT Pro’s built-in browser (from a bookmark of the page).

Note that I’m not registered for that site, so I couldn’t login to it for the full display.

However, at age 77, I’m not highly motivated to try to become “Slimmer, Stronger, Sexier”. My lifelong attitude towards workouts is based on reading about our primitive ancestors, when I was young. Those ancestors were constantly in a workout mode for sheer survival, whether hunting critters or running away from critters that wanted to eat them. They lead short and brutish lives. So much for exercise, I concluded. :slight_smile:

No Way are you that old! Absolutely No Way! :smiling_imp:

Leaving that aside, thanks for all your helpful comments here in the forums. :laughing:

-Tod

Yep, it’s true, you young whippersnapper. :smiley:

I spent a bit of time troubleshooting this. I uninstalled Glims, and then uninstalled a few other plugins (1Password, Ecamm, etc) that I had in the InputManagers folder. I never could get it to work. The Edit menu highlights and an error alert sound happens, and if the URL is highlighted, it’s replaced by a “c”. I then tried it with selected text in a TextEdit document and it does capture that. Incidentally, I doesn’t actually make it into the database, it’s captured into the inbox folder in Application Support or wherever it is. I assume that will be eventually worked out as it is a known issue.

I’ve given up troubleshooting it for now since it doesn’t capture the way I want it to anyway. Let me know if you want me to try something specific.

I’m crazily thinking of finding some way to automate capturing in Together and then shuffling it over to DevonThink. I’m going to keep looking into the customized Applescript angle and see where it gets me.

That’s interesting. When I capture the same page as a webarchive this way, it draws much faster and properly as compared to dragging the URL from the address bar of Safari to the Sorter. Not sure why, but it seems like there’s a lot that’s unreliable with the Sorter at this point. I’m going to keep messing with it.

The difference has nothing to do with the Sorter, per se. The WebArchive capture by the Service is a different beast.