certain file naming makes it hard to search?

I name my file like this:

2014-06-06 - file name

But when i try to search the whole filename nothing came up, even though i know that the file exist.

For example,

searching for “2014-06-06” (no quotes) will return the file. Or "2014-06-06 - " will return the file too. But not “2014-06-06 - file name”


I name many of my documents the same way, and I don’t have a problem finding my documents with any of the criteria that you listed. Are you using the toolbar search or the global search? If you are using the toolbar search, try the global search and see if you have the same results.

i tried using both. Toolbar and the global search.

Restarted etc to no avail. It’s certainly weird

Just to ask the obvious - are all the search settings ok? I.e. Not set to in selection, or any other restrictions?

In your example, the dash in front of the filename looks different from the ones between the numbers. Is that an artifact in the post? Also, it seems that you have spaces before and after that dash. If you don’t put the whole thing in quotes, I believe the search will interpret this as the date, -, and filename being separate strings to looks for.

In DEVONthink searching, a hyphen surrounded by space(s) front and back is the “NOT” operator. So

2014-06-06 - file name

is equivalent to

"2014-06-06" NOT "file" AND "name"

Which has the effect of explicitly telling DEVONthink to ignore the thing you want to find. :confused:
Do what @gg378 suggests - “put the whole thing in quotes”

oh ya, putting everything in quotes worked. I’ve been telling devonthink not to search for file name lol.

Thanks guys, I’ve been pulling my hair out on this one.

I have the exact issue but putting the name in quote does not solve the issue :(. Maybe this won’t work in devonthink 3?

I don’t have a suggestion, but I do recommend you put a screen shot of your search criteria along with an example of the items you would expect to be found.

Try the condition Name contains or use a query like name:~string

Hyphens and underscored aren’t indexed, therefore ignored. Replace them with spaces in the search.

2021-08-19 Some_File
Search for: 2021 08 19 Some File