Change default browser

Hi, I’m a new user to DevonThink3 and have tried to find this point in the forum but with no success - though that may be my error so apologies in advance if this has been discussed before.

A large part of my stored data is URL links to YouTube content - I drag the URL from my browser to DT3.

When I select the content in DT3 it automatically starts the content in the internal browser. The problem is that this is not signed in to my YouTube Premium account and thus I immediately get the adverts playing through my speaker.

I have tried to sign in to YouTube through the inbuilt browser but Google won’t allow this and gives an error message of ‘Couldn’t sign you in - the browser or app may not be secure’.

So my questions are;

  1. Is it possible to turn off the ‘autoplay’ of loading the URL in the internal browser so that I can then use the ‘right click’ option to open in my default browser?
  2. Is there a way to sign the internal browser into google - ie how do I make it seem acceptable to Google?
  3. Is it possible to change a setting so that if I do select a URL entry in DT3 then it will open the URL in my default browser rather than the internal browser?

Thanks in advance.


Did you try the „double click opens in default app“ option in the preferences?

1 Like

I hadn’t spotted that - many thanks.

I still have the issue that I tend to navigate with the keyboard, so frequently move the cursor up and down the screen - as it moves across the items that are URL links they automatically start playing in the internal browser - which is a tad irritating - so is there anyway to turn this off? (I promise I have reviewed the settings this time :slight_smile: ) as I can’t find an option for this.

You might want to join this feature request.


1 Like