Change "sync manually" to "sync always" does not work


I had to set up DevonThink To Go again on my new phone. When first syncing, I had manual syncing activated, so that only metadata was synced to the phone, but not the data itself. Today I changed the setting to syncing always, but this does not work. Syncing itself works (I created a new textfile in the inbox which synced instantly), but for all the files in my databases I can still only see the metadata and the option to download them manually.

Could someone please help? I need all the data offline on my phone! Thank you!

Can you please post a screenshot of the setting that you changed, so I can compare with the settings on my device.

sure. hope you don‘t mind it‘s german

@eboehnisch: When changing a sync location to a full sync, the Download Files option for databases from that location are set to Always. However, it doesn’t generate any sync activity so the files are not downloaded.

When you then tap the cloud toolbar icon, does it then download everything?

No. And hours later, there is no change. The files are still not downloaded.

Same here. I tried saving some new files to the database on the Mac and then syncing them → worked! Files are downloaded to iPhone. But all the older files, where metadata has been synced before, still are not downloading to iPhone.

Please open a GitHub issue for this, @BLUEFROG. Thank you.

Issue filed.

Hi! Looks like you’re working on it, awesome!

Unfortunately it’s still not fixed in Version 3.5.4 - same behavior as before. I tried changing the property in the (local) location from always to manually and instantly back to always. As a result I receive a message: “Could not download documents”. Syncing itself works.

I assume you mean 3.5.5? It almost couldn’t be, as 3.5.5 was probably submitted to Apple 2 days ago (so just 2 days after DT determined that your report was correct and required intervention) and “file an issue” at least suggested that the matter required investigation and fixing (rather than one of DT’s rapid fixes).

Edit: no, DT excel again; from the release notes for 3.5.5: After switching a sync location to Download: Always , the items were not downloaded automatically. Fixed.

1 Like

Correct, I meant 3.5.5. I saw my bug as fixed in the release notes, so I retested - which failed.

  • Do you have more than one sync location active?
    • If so, what is the Download Files set to for each?

I have only one sync location, which is my MacBook (local network). It is set to „always“, syncing two databases which are also set to „always“.

You cannot set a database to Download Files: On demand if the sync location is set to Always. That would be an illogical situation.

The sync location must be set to On demand if you want to shallowly sync databases syncing with it.

As described, everything is set to ALWAYS - the sync location as well as the databases. The problem remains, that the very first sync was a shallow sync, only after which I changed the setting of the sync location from ON DEMAND to ALWAYS - with the result that only files that where created after the initial shallow sync are downloaded to the iPhone, whereas all the older existing files are not downloaded.

I am pretty sure that I can solve this by deleting the databases from the iPhone and syncing again from the start. I will do this in the coming days, just waited to maybe contribute to the analysis of the problem.

To clarify for your database in question:

  • the sync location for the database is set for “ON DEMAND”
  • for the groups in that database that you wish to sync all the time without your intervention, you have set them them individually as “always”
  • for the groups in that database that you wish the sync to remain the same as the overall database, you leave as “on demand” with no change.

Far as I can tell, the above works for me.

Yes, as simple fix might be to delete the database(s) from the iPhone. I’d probably do same and start again. But i recommend you first do one database and get it working as you expect before working with others.

:wink:I hope this not backwards!

Thanks for the clarification.
This is an issue we are currently investigating. Thanks for your patience and understanding.

Actually, after switching the sync location first to “on demand“ and save, the back to “always” and save should request a full sync with version 3.5.5.

I tried this - did not work in my case. When switching back to “always” I get the error message posted before.