Changing hidden preference AdditionalPlainTextExtensions has no effect

I would like DEVONthink to treat files with the extension .canvas (used by Obsidian) as plain text.
Changing the hidden preference AdditionalPlainTextExtensions had no effect. This is what I entered in Terminal:

(I had changed IndexRawMarkdownSource to true earlier - and that had the desired effect).

If I change the file’s extension to .md, it is displayed correctly in DEVONthink and Finder/Preview, so it really is a plain text file.

What am I doing wrong?

This is odd. It is working now - but only for files created after changing the setting. The original file still does not display as plain text. Newly created copies of it are displayed correctly.

File > Update indexed items has no effect.

Moving the file out of the indexed folder and back in does solve the problem.

I apologise for crying wolf

No worries and that is the correct behavior. Changing the preference won’t retroactively index those files as plain text.
Reimporting (as you’ve seen) or rebuilding the database would resolve this.

Thank you, Jim

You’re welcome :slight_smile: