Charset/encoding issues with DTP 1.3.4 on Leopart 10.5.1


I’m evaluating DevonThink Pro, and I have stumbled upon an issue with character encoding of rich text files. When I create RTF in DevonThink and write some czech characters in it, everything seems to be fine as long as I don’t change to another file. When I do that and return, the czech characters get garbled.

When I use just plain text files, everything works.

There are no problems with czech characters when I use TextEdit, including saving and re-opening the files, but as soon as I try to import them into DTP, the same thing happens - the characters are changed again in the same way.

Here are sample files with the same sentence, one I exported from devonthink, the other I created with TextEdit. The preamble seems to be the same, but the characters in question are different indeed.

Is there any system/DTP encoding preference that I missed? I don’t recall having this problem with Tiger (I did a clean install of Leopard, not upgrade).


{\fonttbl\f0\fswiss\fcharset0 Helvetica;}

\f0\fs24 \cf0 P\uc0\'f8\'edli\'9a \'9elu\'9dou\'e8k\'fd k\'f9\'f2 \'fap\'ecl \'ef\'e1belsk\'e9 \'f3dy}


{\fonttbl\f0\fswiss\fcharset0 Helvetica;}

\f0\fs24 \cf0 P\uc0\u345 \'edli\'9a \'9elu\u357 ou\u269 k\'fd k\u367 \u328  \'fap\u283 l \u271 \'e1belsk\'e9 \'f3dy.}

Are you definitely using v1.3.4? I’ve created an RTF file using the second RTF code, imported it to DEVONthink, modified & saved several times. But everything’s working as expected.

Or do you have an example sentence I could enter into a new document on my own? Because I’ve also taken several notes at, still no problems.

Yes, I do, I even tried to completely uninstall/download/reinstall DTP already, see this about box.

My favourite is “Příliš žluťoučký kůň úpěl ďábelské ódy.”, as it seems to contain all czech accented characters. Here are some more screenshots of DTP:

  1. I just create the file and the sentence, everything is right as it should be:


  1. I clicked on another file and returned:


  1. 2 of the characters in the original sentence are breaking all the rest, so here I used the sentence without them:


  1. and now, here comes the weird thing. You mentioned taking notes from, so I tried it. When I take a note it looks like this:


The links are ok, but the text is garbled, at least some characters (ř, č). If I fix them, leave and come back, they are broken again. I tried to set the same font as the links etc., nothing worked.

The strange thing is, that the broken characters have by default another font then the rest according to style info - everything is Arial, these are Lucida Grande. But changing the font to Arial does not make it work, as mentioned above.

But, amazingly, changing the text to a link works. As soon as I make it a link and fix the broken characters, it stays right all the time. Why?

Any ideas what to try?

I’ve pasted the above sentence into several new RTF documents, using Times, Arial, Lucida Grande and Helvetica fonts without “success”. Everything’s working as expected over here.

What is your default font for RTF documents? Do you have an example on a Czech website for me not being stored correctly so that I could reproduce this over here? Thanks!

Ok, I just found out, that the problem occurs only if I choose czech as my preferred language in International preferences pane. When I choose English, everything runs just fine.

Could you please try to set Czech as preferred language and confirm this behavior? Thanks in advance.

Hi, is there any solution of this problem? I try DTP 1.5 and I have the same problem with several CZ characters. What me to do?

The only solution right now is to use a western system language but the next maintenance release will fix this.