CKErrorDomain 2 when attempting to create the new iCloud sync

Just rebooted, and I get the exact same response!

Do you have the same issue after cleaning the sync location, then setting it up again?

That I do not understand! I don’t have an iCloud sync location/store, so I can obviously not clean it.

I only have a Dropbox sync store (that I planned to abandon in favor of iCloud). Cleaning Dropbox store can not reasonably help iCloud problems. I cannot even create an iCloud sync store! I get the error I described in the first post of this thread.

I have the same problem. If I try to “Add iCloud (Cloud Kit) Sync Store” and then hit “OK” I get the CKErrorDomain 2 alert. I’m running Big Sur on multiple Apple machines, and it doesn’t work on any of them. Like Harald, I have a perfectly functional sync system set up with dropbox, but I was considering switching.

I should add that I don’t really know what Cloud Kit is – perhaps it requires a special account? I have purchased iCloud storage, associated with my apple ID, but maybe that is not what this is? If so, is there any way I can use my iCloud storage for sync?

Welcome @pjvp

These are the only two reports of this error at this time, so it’s unclear what is causing the issue.

Does DEVONthink have Full Disk Access enabled in Sytem Preferences > Security & Privacy > Privacy?

No, DEVONthink is not listed among my 4 apps that have Full Disk Access (which were added into that list automatically by default).

I now manually added DEVONthink into this list, restarted DEVONthink, and then attempted to create an iCloud sync store. But, I get the exact same error response I reported at the beginning of this thread. So I removed DEVONthink from the list.

For the best operation, DEVONthink should be given Full Disk Access regardless of this situation.

The same problem here: even after the full disk share, the mentioned error message “CKErrorDomain 2” appears.

Problem solved: In the “System Preferences” under “Apple ID” “iCloud Drive” must be activated. Under “Options”, “Devonthink” must then be selected. After that, everything worked.

3 Likes

Welcome to the forums, @asku and thanks for sharing your findings.

Making a note of it here. :slight_smile:

Good catch!
That trick works also for me on Mojave. But it’s a bit strange though, since I have for years had sync of Notebook, Reminders, Contacts, Calendar & bookmarks, all via iCloud, WITHOUT the need to have iDrive enabled!

I have been very reluctant to enable iCloud Drive because Apple seems to take for granted that if iCloud Drive is enabled they feel entitled to upload everything between heaven and earth to iCloud!

I have wireless internet with max 30 GB per month so I have to be careful. I store mail on my server, so I do absolutely not want Apple to start uploading GB of duplicate mails to iCloud! That would be disastrous! And although a few Number documents would be nice to have in iCloud, I’m afraid of having EVERYTHING there.

I know that there are checkmarks for various apps under iCloud > iCloud Drive > Options > Documents, but I don’t understand if that means those apps always will store everything in the cloud, or if I have some control over what is uploaded and what is only stored locally? Maybe someone here can explain the details to me?

Just disable anything you don’t want shared to iCloud Drive, most importantly do not enable Desktop and Documents folder.

I have this problem too - Error while setting up location “iCloud (CloudKit)” - I can’t select the sync entry to delete it and try again. I have iCloud Sync enabled, but Documents and Desktop sync switched off. How can I remove the sync entry so that I can set it up again?

I managed to fix it for myself but I am not sure what it was that I did to make it work:

  • iCloud Settings,
  • iCloud Drive,
  • Disable devonthink
  • Close all the windows
  • Reboot
  • back to iCloud Settings
  • iCloud Drive,
  • Enable devonthink
  • Open devonthink
  • Set up iCloud (CloudKit) synchronising - just suddenly worked.
1 Like

Thanks for sharing the details here. It’s appreciated.

1 Like

I’m having the same problem. Unfortunately none of the troubleshooting steps described above seem to be helping. A further detail: I’ve unchecked the iCloud (Legacy) location, but when it’s highlighted I can still see the databases there.

Does Bonjour synch work? Faster and more reliable than cloud-based. And could try another cloud service. Apple’s services are not so reliable and certainly not very debuggable as you see.

Bonjour sync does appear to work (haven’t actually downloaded any databases but they’re visible). I don’t really want to change cloud services unless OneDrive is supported, which as far as I can tell it isn’t.

Sounds like nothing working. :pensive:

All this does work for me. But I know this does not help you very much.

However I recommend you start fresh, reread the DEVONthink Handbook on sync set up. Clean everything and start with getting Bonjour to work as it is the best and easiest to setup. The just try to get say Dropbox working with a free account and a small database. Just to confirm you can get a cloud service to work. Forget about Onedrive till it is part of DEVONthink’s world (unlikely). Then tackle CloudKit (but there are few things that Apple provides to help you)

Currently downloading the databases to my new Macbook Air via Bonjour. Once everything’s there I probably won’t really even need DT on the old Mac mini at home. I don’t really use DT on my phone, but maybe I’ll have to revisit if I ever get a new iPad capable of running the current DTTG.