CKErrorDomain 4

I’ve been searching this forum and can’t find the answer for my problem: Since a week, Devonthink gives (in the log) an error "Saving asset failed - Network failure (CKErrorDomain 4). This log entry comes up every 20-30 seconds…,.,continuously. My internet is working fine. I did the Verify & Repair database (successfully). I have quit Devonthink and re-opened. I have restarted the macBook. I have reduced the number of max sync connections down to 1, up to 6, up to 12…did not change anything. I have let it go for 24 hrs- no change. I have tried on different days. Finally I have cleaned the CloudKit location (log shows successfully cleaned). When I then upload the database it starts uploading but within 30 seconds I get again Network failure and the uploading stops. What to do?

As your internet connection is fine and as Apple’s cloud services are having issues this week again, the only possibility would be to switch to another sync location if this shouldn’t work again soon.

Thanks for the fast response (as always), but, sigh, now need to set up a different sync method and they look more complicated. I understand it’s not a Devonthink problem.

I’m having the same issue. iCloud is being very unstable these days.
In fact, it has been unstable.

I did try changing to Bonjour sync, but ran right away into a whole host of problems. Found Bluefrog’s write-up on setting up Bonjour but also saw that several people had Bonjour connection issues. Followed all the tips (took out Little Snitch, deleted Adobe plugins per Bluefrog posting, checked that the firewall was off, etc.), all to no avail. However I then noticed that in the meantime Cloudkit syncing on my laptop was running again (uploading without errors). My iPhone synced also. My iPad did not; so I deleted DTTG, reinstalled and started downloading the databases. The whole activity has taken two days. I’m happy it seems to be running again, but also feel that this sync is the Achilles heel for Devonthink. How long will Cloudkit work? Should I subscribe to Dropbox to have a backup solution?

CloudKit is run by Apple. So only they know how long, how reliable and how fast it works (or not). OTH: many people seem to use Bonjour without problems, so it might in fact be helpful if you described your approach and your problem in more detail. “To no avail” does actually not tell anybody anything.

Another approach that works well for many people is using WebDAV with a local NAS to sync DT databases. The hardware is more expensive than a Dropbox subscription at first, but obviously it has to be paid only once. And you have full control over your data without having it send over to a third party.

In any case, iCloud (in any incantation) seems to be the most unreliable sync possibility. I dare not use the word “solution” in this context.


Thanks for your comments. Once Cloudkit worked again I gave up on Bonjour (and hence the vague description). Your post motivated me to get back to it and try to make it work. DTTG on my iPhone sees my macBook but then gives me these errors: AsyncSocketErrorDomain 2 and .manifest missing. I then deleted the DTTG from my iPhone, reinstalled and tried again. Now it worked! AND CloudKit still works too. So I have a backup solution (btw, I used to run via a Synology NAS but now spend half my time working/traveling in a RV and the NAS is not practical). Thanks for the motivation :slight_smile:

You could in fact set up a VPN on your NAS and use it access the WebDAV server safely from abroad. Or, if you’re less paranoid, simply set up port forwarding on your router, which would still allow you to use the NAS from abroad.

I’m going to try that! Btw, spoke/wrote too fast regarding Bonjour working. It was syncing but just now finished with the message (in the log): Couldn’t upload 6108 pending files. This is the total number of items in the one database I was trying to sync with Bonjour. Back to the drawing board.

Check the forum for threads dealing with this message. There seem to be several ways to remedy that.

1 Like

but just now finished with the message (in the log): Couldn’t upload 6108 pending files

On the Mac or mobile device?

on the iPhone…
Is it ok to have both CloudKit syncing on AND Bonjour syncing on or does that confuse things?

I’ll of course let @Bluefrog reply to your question, but in the meantime don’t you think that if it did not work to have a multiple syncs “on” that the DEVONthink developers would have prevented on the dialog box to allow multiple “on” syncs?

I run Bonjour, WebDAV to a local NAS, and Dropbox (with a very small and works-in-progress database) routinely. When away from “Global HQ”, of course Bonjour and WebDAV do not work and will catch up on return. From experience and from watching this forum, Apple’s CloudKIT is unreliable for many and is for you probably your greater risk of continued sync failure than being concerned about about Bonjour method for syching. Just my “two-bits”.

You can use several sync methods simultaneously.


Good point. It’s just that, having these issues, I’m looking for what could cause them.
After reinstalling DTTG on my iPhone it now ‘sees’ my MacBook and connects. Sync starts ok, just continue to get a number of errors (such as couldn’t upload 3 pending files, database busy, Asyncerrors). Oh well, maybe just live with, most of it works now. [I use my phone for making new notes and collecting info, my iPad for reading and annotating and my MB for archiving]
Chrillek: Thanks for confirming
This forum is great!

Glad you are going again, but reinstalling surely had no part of resolving this. Apple’s iCloud is throwing you these error messages, so it down to them. Nobody but them, and maybe not them, know the root cause, seems like.

Sorry I’m late. Eye appointment out of town today.
If you continue to have issues with DEVONthink To Go, in DEVONthink To Go, select Help > Contact Us to start a support ticket. Thanks!

Just an update: I changed my wifi hotspot. I was using a Netgear Nighthawk MR1100 and now changed to a Simtell (with an eSim card). Everything works! Synced very fast :slight_smile: So it was the router blocking Bonjour traffic.


Awesome! Thanks for the follow-up :slight_smile: