Classify Current database only and search

I am finding that the “Current database only” checkbox gets ignored as soon as you type a search in the classify search bar.
Is there a way to stop that from happening?

It’s currently a global search, the settings are only relevant for the automatic suggestions.