Clip to DEVONthink as clutter free produce wrong character set

Hi there,

I searched but did not found a similar thread here - if I missed it please link back.

Today I got some strange behaviour when clipping to DTP3 using Safari (no matter if using the share function or the DT plugin).

Clipping a website as is to webarchive or PDF works as expected. When using clutter free mode the character set of the captured file seems to got changed. All German special chars (like ä, ö, ß or similar) change, see screenshot attached.

normal clip without clutter free

“clutter free” clip (I marked the spots):

Further testing shows, not all websites produce this error, some tested clip clutter free really fine with all correct special chars. Others don’t. So I expect a coding error in “wrong clipped” sites.

Does anybody has an idea for a workaround or a solution?

Thanks in advance.

What’s the URL of the page?

Thanks, we’ll investigate this. In the meantime one workaround might be to select the interesting part of the article and take a rich note (see Services) then.

Trying this produces - even with snippets - the same crude result when clutter free is selected for the rich note.

So it definitely seems to be a coding error or a result of some “java script voodoo” on the source site.

As this particular site has a “print this article” button I use it to print to PDF and then import to DTP3.

Thanks for investigation!

See menu Services > DEVONthink 3: Take Rich Note in Safari.

Thanks, but this makes no difference when clutter free is set. The same wrong characters are in the clipped file.

Did you use the suggested menu item? Because it does neither use Clip to DEVONthink nor the clutter-free option. I didn’t suggest to use the rich text option of Clip to DEVONthink.

Probably not. But under DEVONthink3 -> Services (Dienste) is no “Take Rich Note in Safari” option.

Have I not enabled something?

My way was Tools -> Get (? German version of the UI: Erfassen)

In Safari there is no: Services -> DEVONthink 3 menu item either. Same as in the DT screenshot.

This service should be enabled & available by default after selecting some text in Safari. Services can be enabled via System Preferences > Keyboard > Shortcuts > Services.

Ahh! The selection did the trick - all and more services become available then!

PS: Help > Documentation > In & Out > Services