Clip to DT transparent

First, thanks for the great extension! I especially like the keyboard shortcut.

I am having an intermittent problem with the bookmarklet and the extension.

When I use the bookmarklet, I get a transparent window, with only the white border and the DTP icon. The page itself dims.

When I use the extension, this behavior occurs sometimes, but if I refresh the webpage first, I get the normal black background.

Something I should try?

This has started happening to me, too. Worked fine on Friday, but now it’s not working at all.


This morning it is working again properly, either through the bookmarklet or through the keyboard shortcut.

Same problem here.
“Clip to DT” (version 1.1) seems to interfere with the extension “ClicktoFlash” (version 1.6.1). Disabling “ClicktoFlash” solves the problem: both the bookmarklet and the extension work as they should.
I had not much time to test this - but maybe it’s the solution…

Clip to DT is the only Safari extension I have tried, and it is transparent for me too. I had been using the Clip to DT bookmarklet, which was the “smoke” type Growl interface. When I upgraded Safari to be able to use extensions, I installed the Clip to DT extension. Then Clip to DT became transparent, and useless.

I uninstalled the Clip to DT extension, and the Clip to DT bookmarklet worked as before.

Is there a conflict between the bookmarklet and the extension? Or what?

In my case, I didn’t even know about the extension until the bookmarklet went sour. The extension actually seems to work, until I use the bookmarklet. Then both go bad. Closing and re-starting Safari fixes the problem, until I use the bookmarklet again.

Also, ClickToFlash seems to have nothing to do with it. The bookmarklet still messes up, no matter the status of ClickToFlash.

Interesting. Once I uninstalled the extension, the bookmarklet started working fine, and has ever since. So in my case, I’m sticking with the bookmarklet. Something odd is going on here, however.

I tried disenabling the extension, but the bookmarklet still doesn’t work.

I agree with you: very odd.