Clipping PDF from iOS Safari to DTTG does not work...often? always?

As usual, DTTG is a constant disappointment and does not see any larger fixes and enhancements…

But…

At least clipping should work, or not?

I constantly run into problems, when trying to clip a PDF from Safari to DTTG!
This time, I tried http://www-fourier.ujf-grenoble.fr/~parisse/giac/cascmd_en.pdf and added the tags Algebra Mathematics Xcas and PocketCAS.
It did not work.
Not at all.
I tried about 4 times, with DTTG running in the background, not running in the background, killed Safari inbeetwen, tried again…
Nothing.
A search for “tags:Algebra” gave zero documents.

I then gave up, shared the PDF from Safari to PDF Expert and just out of curiosity, tried to clip it from PDF Expert to DTTG.
And that worked!!!

So, again, something is not fully working, has a bug, an oversight, missing knowledge, or whatever… But technically, it seems to be possible!

So please, please, please, finally fix some stuff in DTTG, if need be, with the help from Apple.

Thanks

I just tried that and it worked after DTTG was done indexing, which it did after Uploading/downloading all the stuff… Maybe you were too impatient?
As I understand, the tagging is not instantaneously added to the searchable index.

Though I currently do not see much use in the more complex search-terms until we can save a search tbh…

Yes, sometimes it does also work for me.
But not every time.
And without any indication why that is.

If DTTG finds an request to import something, this should be visible somehow.
This way, we could directly see that this worked.
And it should also show when and what it is doing.

I tried four times, i touched the cloud icon several times, i drew on the left site to force an update - to no avail and without any output.
I also scrolled down on the INBOX to see if there is this text that shows if it is indexing or something.
But nothing.

Just because it sometimes or even often or some people works, does not mean that it works reliable!
And that’s the problem.

And if time was the problem, i now should have 5 instances, right?
There is only one!

I think I understand the Problem.
Try to copy the PDF to DEVONthink.
Clipping means that DTTG tries to download the Site and reprocesses it.
It worked with „copy“ for me but „clipping“ failed (maybe you have to make the shortcut visible?).
Personally I think clipping is more of a „static text“ thing. It did not work for me on some dynamic websites.
Right now, I create a PDF from a site I want to push to DEVONthink and then copy that via the shortcut to DT. That works reliable for me.

//Edit: my bad. It DID work when clipping. I was looking in the wrong folder…

To be honest, I never used “Copy to DTTG”, as this would not allow to add tags, right?
The site and PDF URL I quoted is pretty static, I think…
But yes, dynamic sites could prove to be a problem.

But this again just shows that DTTG should be way more verbose about what it tries and what’s the result of that - including reporting any problem!

You can add tags in the devonthink app after the object is imported.

:joy:
Thats right. What I meant was, from a website content type: I tried clipping and it had Problems with websites that loaded dynamic images and had javascript etc…
Thats why my current workflow is basically to create a PDF from the website and then copy that to Devonthink.
Clipping is IMHO more useful for simple Websites with no dynamic content.

It would be interesting what went wrong. Though Clipping seems to be a somewhat complex process which is highly dependent on the content to be clipped.
My guess is, that Devonthink tries to import the clipped object in the background and gets shut down by iOS (IOS sometimes kills background tasks to free memory) while “copy” means that Devonthink gets the foreground and just a file in the filesystem to put into its database.
What iOS device do you use?

I have and use:

iPhone 8, iOS 13.1.1

iPad Pro 12.9 2nd gen, iPadOS 13.1.2

iPad Pro 9.7, iOS 12.4

iPad Air 3, iPadOS 13.1.2

I had and have similar effects on all devices.
But of course 13.x is quite new.

Are you saying, that DTTG runs in the background when something is clipped to it?
That would be a strange architecture.
A better implementation would be, to just queue any such requests in some “Import” directory for each App, and the App reading and handling that when it gets started the next time.

So, that the OS just prepares all data for the import but no starts the App that shall import something.

I don’t think I had Problems with my iPhone 7 so its probably not a limit of the hardware…

I think the “Clip to” feature was implemented with small text-snippets in mind and then “grew” to include more types of content.
For Small snippets, especially if they are just in-memory-Strings/Images, some kind of background-mechanism makes sense.

In general, I also see Apps often “start up” when switching: IMHO the Memory of I* Products is, compared to Android/PC, limited. Of course that could be a compromise because RAM really eats into the available battery.

I read somewhere that the Apple scheduler in the Background is quite aggressive when it comes to kicking Apps for their RAM: Apps are expected to basically “shut off” in an instant it the iPhone needs to take a call or the Foreground-App needs more Resources.

Just for fun I just checked:
iPhone 7/8 has 2GB of RAM

Top-Models:
Samsung S10+ has 12 GB of RAM
iPhone 11 Pro Max has 4 GB of RAM

//Eidt: Keep in Mind. This is all speculation :sweat_smile:

Hi, I tried to share a PDF-Document from Safari via share menu (iOS13) to DTTG but it doesn’t worked. Instead of a PDF file a link was clipped. So I share the file from Safari to my cloud space, no problem with the same file. When I share the same file from cloud space to DTTG there is no problem! Why doesn’t work this sharing directly from the safari on iOS?

You can follow my workflow with sample of DT documentation (PDF) here:

Open this link with iOS Safari and share it to DTTG:

The same action from cloud space:

And that is what I expect.
(All other actions with tags, renaming, flags are not in my focus.)

Any ideas?

I read somewhere that the Apple scheduler in the Background is quite aggressive when it comes to kicking Apps for their RAM: Apps are expected to basically “shut off” in an instant it the iPhone needs to take a call or the Foreground-App needs more Resources.

This is true and also tuned for mobile phones as they are deemed to need to conserve resources more than an iPad, though both are affected to some degree. iOS can terminate any app it feels is using too much resources, especially when the app is in the background. Even the Background App Refresh only allows ~30 seconds of activity before iOS cuts it off.

The App simply needs to indicate that it is doing something, esp. with important things like sync, upload or download,

Anyway, you did not state how this works: If I share something from Safari to the not currently running DTTG, what exactly happens?

I don’t believe that the App will be started at this moment.
I suspect, that iOS just adds the URL (or the whole file?) to some import folder of DTTG.
And DTTG then loads and imports, when it is started the next time.

Or?