Cloud Icon Always Shows Items to Sync

I’m currently using iCloud as a sync store (I gave up on Dropbox after it was shown to be unreliable). I have 4 databases in DTTG that sync with my desktop DT, with full Download Files set to Always on all of them.

Now, every time I try to sync (swipe down at main screen or tap sync icon), the little cloud icon shows a blue dot, which apparently means “there are items to sync”. Ok, so why doesnt it sync them?

I get no error messages, just a little icon saying I need to sync, that never goes away.

Any ideas? DTTG int very informative, it doesnt even tell me which database or how many items.

You can check this when you visit each database. The cloud icon then only shows you the status for that database. Usually this happens when the database in question cannot sync with its sync store, e.g. because it is not available, offline, or disconnected.

Ah, didn’t know that’s how the cloud icon worked. I checked and found 2x databases that show a grayed-out cloud icon (with a gray dot). Nothing I do will persuade them to sync (I tried turning sync off then on in Edit Locations).

Note that this is with DTTG on my iPhone. I also have DTTG on my iPad, and that syncs (also using iCloud) all databases just fine (including the two that fail on my iPhone).

So, short of uninstalling DTTG on my iPhone and starting over I’m not really sure what I can do to recover or debug the problem. Any suggestions?


It is a known issue that iCloud can stall, a condition over which we have no control, nor can we even detect it.

Have you tried rebooting the device?

Just tried a reboot … no change I’m afraid.

Some people have tried signing out of and back into iCloud in Settings > your Apple ID. And that is anecdotal as we can’t reproduce an issue at will. Just reporting what some clients have said worked for them.

Grayed-out means that the sync system thinks that the sync location for these two databases is not reachable or available. Did you maybe once have set up multiple sync locations, anything that could trick DTTG into believing that their location is “not there”?

I’m having the same issue and it’s been like this for a long time. 4 out of 6 databases show they are unable to sync, but when I add a new note to the inbox for one, it syncs just fine, do the sync service and database are available. For one Db, I checked the counts and they all match up.

Is there a way to find out what’s not synching, in either DTTG or DT?

What kind of sync are you referring to?
A Dropbox sync?

I’m only using iCloud at this time. Also, when I go into the prefs for any of the apps and look at the iCloud sync, they all show a time of when they last connected and are within seconds of each other.

Some additional info, both my iPhone and iPad have the blue dots on the cloud icon, but the Mac does not (the Sync All button has no dot badges).

You said…

4 out of 6 databases show they are unable to sync, but when I add a new note to the inbox for one, it syncs just fine, do the sync service and database are available. For one Db, I checked the counts and they all match up.

This sounds like the 4 out of 6 are indeed syncing as expected. Is this correct?

Note: The dot on the sync icon isn’t a fine-grained control, i.e., it’s not a highly sensitive gauge that is reacting exactly as events happen.

Also, the dots on the devices have no bearing on each other. In fact, the dots on the two mobile devices has no relationship to each other. Syncing on one devices is unrelated to syncing on another as they are isolated devices and independent environments. This is no different than having two automobiles, both of which run well or poorly regardless what the other is doing.

If the database(s) are sync changes properly, I personally don’t pay much attention to it.

No, only 2 show no dot on the cloud. The other 4 had the grey dot badge on the cloud icon.

That’s what I’ve been doing, though I worry not all of the notes/documents are being synched. There are too many for me to go through each one and check.

Have you quit and relaunched DEVONthink To Go or rebooted the device recently?

They were both updated to iOS 12.4 yesterday, so full restart. Just quit both iOS (iPhone, iPad) apps and reopened them, forced sync (swiped down). Cloud icon drops dot for a few seconds, then returns.

In DEVONthink To Go 2, select Help > Contact Us to start a Support Ticket.

Is there a way to send a Support Ticket without using Apple Mail? I don’t use that app, preferring another for email.

Just start one from here…