Color Text Editing Major Mishap

I was editing something for someone using red, blue, and red text colors interspersed throughout the body of a regular, new text file. All fine and well.

Then when I did a ‘command-a’ to select everything for a copy and paste, immediately all of the selected text turned to blue! Ahhhh! :open_mouth: I then had to re-do all of the color text editing again (very laborious) within ‘Mail‘. :imp:

Please tell me what happened. Did I do something wrong? It was just a regular text file in DTP2. Why didn’t the all of the text color changes maintain their color status?

That’s completely handled by the text engine of Mac OS X but selecting shouldn’t change anything. And usually doesn’t because we’ve never received any similar reports. Did you edit a plain or rich text? And are you sure you’ve pressed Cmd-A and not accidently another shortcut? Did you try Edit > Undo?

I was using Rich Text. BUT, here is what I just discovered, now. I was replicating the same actions and coming up with the same results UNTIL I closed the color palate window. When I did this, the colors maintained their status! So, the problem only occurs IF the the color palate window is open, then the all of the text will adopt the color that is selected in the open palate window.

Why does this happen?

Undos did something, but not reverting back to the original colors.

Also, even while the color palate window is open, I exported the rich text file within DT2P as a rich text file and then from within TextEdit I copied and pasted the colored text into a Mail document and that worked fine.

Strange. I still can’t reproduce this over here. Is the “Background” option in the Color panel enabled? Do you use any custom color pickers?

No, the background in the color palette is not checked and I don’t use any special color pickers.

UPDATE: When I got home today, I read your response and did another test. But this time I did not import any text from blog site using Safari, I just opened a new rich text file, opened the color palate window and started typing (in black). Then I started selecting various lines and works to change there color. Then the moment of truth: Command-a. Result: Everything held their color status! Huh.

So, I opened another file, but this time I DID cut and past a blog entry into it and started editing it using various colors. I should mention that the text Color I pasted was a grayish white so I did a Command-a and then selected black from the color palate and commenced editing with various colors, did a Command-a (keeping the color palate window open) and…this time everything turned blue.

Now more strangeness. I opened a new file and did NOT cut and paste anything into it, and just like the first time when everything held its color, started typing in new text and then edited that text with various colors. Then Command-a…everything turned blue as well.

So, I quit DT2P and opened it again, opened a new file, started typing, edited it with various colors, did a Command-a…everything held its color.

So, it appeared that some how cutting and pasting text from the blog site corrupted DT2P even when opening and starting a new file. BUT NOT SO. I started a new file again (while the color window was open) and again everything changed to blue. So it wasn’t about something being brought into and corrupting DT.

I closed DT, reopened it and this time started a fresh text file BUT before starting to type I opened the color palate window and typed in new text, etc, did the Command-a…everything turned blue.

So its something to do with the color palate being open that messes things up.

Why my system, I don’t know either. I do regular maintenance with DiskWarior and keep every pretty clean. I am also running under OS 10.5.8 on an Intel Core Duo.

If this isn’t a but but an anomaly for my only, I’ll just have to remember to close the color window palate or export my work as a RichText file and copy and paste from that program.

2nd Update:

I did a verify and repair of this data base (all other checked out fine) and these are the messages I got:
(see attachments)

Picture 2.png

This was the first message:
(see attachment)
Picture 1.png

Got rid of the two missing data files and the verify and repair worked out. So I don’t think this had anything to do with the color issue.

Is any of the options in Edit > Substitions > … enabled?

I created a new rich text file; went to ‘Edit’ then “Substitutions’ and every item was grayed out except:

Smart Copy/Paste
Smart Quotes
Smart Links

Of these three that were active, only two: ‘Smart Copy/Paste‘ and ‘Smart Quotes’ were select.

Does disabling Smart Copy/Paste fix the problem?

No difference.

I did it three times with ‘Smart Copy/Paste’ un-checked both before importing text and after.

Then I closed and restarted DT2P keeping the 'Smart copy unchecked before closing, although when DT re-opened the Smart copy option was selected again as if there is some kind of default is in effect, so I unchecked it again before typing. Anyway, this time not importing text, but just typing new data right in DT and still the same results when the color palate window remains open.

The only way the color holds its formating is when the color palate widow is closed.

This time I un-checked all the substitutions, even in DT prefs (the smart quotes was the only option) and typed in new data (no copy and paste), did the color edits, kept the color palate window open, then the Command-A… and it held!

However, only this one time! Repeat tests both without the copying and pasting and with new data did not work out.

So, the behavior is eradicate. This has to mean something, either within DT2P or with my system.

Are you able to reproduce it using a new user account or another computer (if there’s one you can use to check it)?

I just have the one computer.

A Guest or new user account can be created on the same computer. This is often done to test whether your normal user account has software installed within the user library that is creating errors.