Hello everyone,

Once again, I would only draw your attention to the fact that the DDTG app it’s still not working (even after the 1.5.1 update!!!).
I’ve already reported the disfunctions of the app on this forum but nobody answered me. I’ve also tried to open a new topic to underline the issue and I’m still waiting for the moderators to approve it (distraction or bad faith?).
I think your behavior is totally unacceptable! I’ve bought the app six months ago and I still can’t pair my devices. Let me underline that both my Mac and my iPad are uploaded to the latest versions of your softwares and I’ve also tried to create an ad-hoc wi-fi network as someone suggested on the blog. Unfortunately the response is always the same: “Bonjour was unable to find computers”.
Since I’m not the only one which is reporting this issues and having lost the faith in you I pretend a refund.


The forum is not the place to ask for a refund. Please start a Support Ticket in the Sales department if you’d like to request a refund.

Hi. Welcome to the forum. There are already a couple of threads dealing with the RTF file problem, but it sounds to me like you are having trouble even starting with the app. I’m on the road right now, so can’t provide details, but from memory, I think I set up the sync with Bluetooth (bluetooth will find the computer and then syncing is done through the wifi network), because I got error messages as well. Syncing with DTTG is, undeniably, a little clunky, but it works! And, it’s one of the few apps that, thankfully, supports syncing without the cloud. Google a bit or search on this forum for details (maybe use bluetooth as a keyword).

Thank you Frobgoblin, I’ve already tried to fix it via bluetooth but the problem is the same. :confused:

Which version of iOS do you run, umberto?

Hi, I’m running iOS 8.1 both on my iPhone and iPad

I installed DTTG two years ago. My memory is quite fuzzy, but I recall that I had initially trouble connecting my iPad and my Mac. I remember that I played with the firewall settings on the Mac, but can’t recall what made the difference.

If you have the firewall on (in SystemPreferences, Security and Privacy pane), choose “firewall options” and make sure that you allow incoming connections for DevonThink. After that, it is always a good idea to re-start everything on both ends, DTPO on the Mac, and DTTG on iOS, or even reboot you iDevice.

I seem to remember that at the time I was astonished that there was not more attention given to the firewall issue in the manual, as this (if I remember correctly) made the difference for me, and many people (hopefully) have the firewall on. This can be quite confounding: Recently, I tried to start iCloud sharing of photos between my family’s iDevices and my Mac. Everything showed up on the iDevices, but not on iPhoto on my Mac. Took me a while to realize that iPhoto needed to accept incoming connections in the firewall. That makes you wonder how the non-expert user would ever figure this out. They don’t poke around in the system. The “it just works” is no longer true. For many people, the “Genius Bar” is the only hope?

Apart from that: Please give the devs credit for the 1.5.1 RTF problem. If you follow the threads here, you will notice that this is something quite subtle, having to do with Apple dropping Webkit support for things as basic as RTF.

gg378 you made my day!!! thank you so much!!! :smiley:
I’ve tried to allow incoming connections from Devonthink in my firewall options. No results.
So I decided to creare also an hoc wifi network. No results.
Then I though: what if I simply turn off the firewall? And it works!!!

Once again, thank you so much gg378!!!

Glad that it worked!
Of course, you’d like to get your firewall up and running again.

Now that we discuss this, I seem to recall a few oddities (but I’m not really sure).
This is what might have happened:

  • tried to allow incoming connections -> still didn’t work
  • turned firewall off altogether, did all the restarts -> worked
  • turned firewall back on and allowed incoming connections for DTPO -> still worked

Normally, I try to write down such experiences in my install log, but it’s hard to be consistent. Sometimes you’re just glad that it finally works and then you have to run off and catch up with something else.

Another hunch from back then: Whenever something does not work, first thing is to check the web for answers. But even today a web search for “Devonthink to go firewall” does not seem to prominently bring up this issue. Blocked connections must be the near #1 culprit. The chances that users have their firewall up should be high. So any guidelines for DTTG (and iPhoto etc) that describe how to set up syncing should prominently state “please check your firewall settings …”.

Now that you can sync, be careful with it: For example, I had several incidence where I grabbed the iPad while syncing, and the rotation of the iPad display caused the sync to go bad. I now generally put the iPad in rotation lock during syncs. If you are careful, syncing seems to work very well. I cannot reproduce all the syncing trouble that all the “DTTG is garbage” people report. I sync my whole set of DBs (many GB, thousands of files).

Other than the rotation issue I found the following: Syncs can become incomplete or wrong when there are items in the trash of DTPO for that given DB. So I generally empty out my DT trashes before syncing.

I’ve also had funky stuff happen when the trash has stuff in it. And, sometimes, I just cannot complete a sync, and it gets hung up at the very end. Other days, it works fine one time, but a few hours later it cannot locate my computer. In short, the sync is finicky.

But, it usually works, and it gives me peace of mind to know that it is secure (not syncing through the cloud), so I am putting up with the minor hassles. I imagine the next version of DTTG will be far superior, and I am very much looking forward to it. However, even with its oddities, DTTG at the moment is (in my experience) quite usable and a key part of my workflow.

Yes, I am also grateful that I have local sync, not through the cloud. The reason is, however, not the one usually discussed. It is not about security. My research is not classified, and I’m not paranoid about it.

But cloud sync is troublesome the moment you have to move relatively large amounts of data frequently. Anywhere but at work, this does not work fast enough, and/or I need unreasonable amounts of cell bandwidth. With my 100 kB/sec DSL upload speed at home, I cannot simply re-sync a few hundred MB of data on a whim. Let alone sync it down to my iPad sitting in the airport or a hotel.

A combined model could work for me: syncing between my Mac and “the cloud” whenever the connection allows it. Normal method to sync to my iPad is via local Wifi/BT, but if I am stuck somewhere without my computer, and the cell connection is the only way to get to the data, I would selectively sync from the cloud.

The latter could currently be simulated by using DTPO on the computer only with indexing external folders, and have those reside on Dropbox. Instead of DTTG, one would use Dropbox on iOS (but with the extremely annoying feature that Dropbox on iOS does not make global syncs, one selectively, even if you sit on the world’s fastest Wifi connection with your iPad.

So for now, nothing beats the DTPO/DTTG combo for me.



Thanks for your clear comments on a subject that is very overlooked and causes a lot of frustration with Users who believe the myth of persistent network connections and bandwidth.

Getting similar symptoms but not quite the same so this may be off-topic. If so, I apologize.

DTTG 1.5.2 (and all updates since 1.4.3) will not load at all. Saw the comments here about the firewall. Perhaps that is my problem too, I thought. (See other post today about not using RTFD docs and not using iOS8).

I thought that maybe a simpler way to test whether firewall and sync are causing my problem was simply to put the iPad into airplane mode. Then it will not try to fight its way through a firewall etc.
Still would not load. Maybe my thinking here is too simplistic.

Am happy to say that release 1.5.4 fixed all my issues with older and newer iPads. Now happily syncing and noting across all of these.