Computer text files - Nim - not shown as text files

If there are trick to force DevonThink to display computer code files such as .nim (Nim programming language) files as text files, just now these just show as a Document icon in the document viewer. I’ve mapped the .nim files to Visual Studio Pro.

You have to tell DEVONthink these are text files. An association with another application won’t make any difference.

See the Help > Documentation > Appendix > Hidden Preferences for an example about AdditionalPlainTextExtensions.

Thanks, that worked. I assumed it would pick up the system document bindings for text-* files. Anyway, was going to see if it worked for quick scan of source code but due to the fact that you could only have one setting for text file font/size globally rather than per file or folder and I have to use a large font size for Tibetan text files it’s not usable. So back to VSCode for quick code searches.