Confusion configuring DT2 Pro Office Web Sharing

I am a little confused on how to best go about setting up web sharing for my DT2 Database from my MacPro which is behind my Airport Extreme-N router.

I have configured my computer with a static IP on my LAN, and I use dyndns.org’s dynamic domain name service, so these pieces of the puzzle I’ve got figured out…

My confusion lies in figuring out public and private ports…(i.e. what port numbers are ideal to use, and where should these port numbers be determined, and/or plugged into?)

The following is in reference to the “Accessing your data over the Internet” section of the help documentation for DT:

Got it…via dyndns.org’s dynamic domain name service…

What port number should be used? Is there an ideal range? Should this be plugged into the 'Port" field of the “Server” panel of DT2’s prefs?

Got it…having setup a static IP in the Network Preference Pane…

You recommend using 8080, I’ll use 8080? Done…

To avoid any unnecessary confusion, can you please have a look at the screenshot below and let me know precisely what to plug-in and where to plug it in (given a hypothetical set of LAN/WAN IP’s and Port #'s)?

Any help would be greatly appreciated…Thanks!

Here is what works for me with DTPO 2 pb1:

Public port: 8080

Private port (as entered in the DTPO preferences): 8081

These numbers would be entered in the Public and Private TCP ports lines, respectively, of the router mapping setup.

The private IP address would be the address shown under Mac OS X Preferences, Network panel for the computer on which the server runs.

Be sure under Mac OS X Preference, Security panel, Firewall tab that Devonthink Pro is listed and accepts incoming connections.

Hope this helps!

Jerry

Just so I am sure that I’m clear on this, does the screenshot below show how you’ve suggested configuring the airport for port forwarding:

Can someone else also confirm that this would be the correct configuration?

Thanks!

Each TCP port in the router configuration table will have only one number:

Public TCP Port: 8080

Private TCP Port: 8081

And Port: in the Devonthink Server Panel would be 8081

That way the outside communication will address port 8080. The router will send anything from port 8080 to internal IP address 10.0.1.201, port 8081.

Hope this works,

Jerry

I tried changing it using the settings you suggested (as shown below), and I can now access the server via this address:

mac-desktop.local:8081/browser/index.html

…but not this address:

my-dyndns-dynamic-domain.net:8081

Previously when I had my settings configured using those shown in the screenshot above (from my previous post), I was able to access the server via my browser using either address…any ideas why I can only access it using the later address now?

I’ve tried clearing my cache, updating the dnydns.org service using their utility updater, restarted my browser, etc…

Here is a screenshot of my current Airport settings that I’ve configured based on your suggestion in your last comment:

Any suggestions would be greatly appreciated… Thanks!

Yes, the router settings appear correct.

When connecting from outside your local network (i.e., from a computer not connected to your router) you will need to specify port 8080. So the address from outside will be
my-dyndns-dynamic-domain.net:8080

This address probably won’t work from computers on your local network. For internal networking it is easiest to use Bonjour.

Jerry

I am having similar issues. I have installed “lighthouse” as suggested in the DTPO help file. I have downloaded from the Devonthink profile from the lighthouse website. This defaults to a profile with both internal and external ports as 8081. I have gone along with these settings. Lighthouse does not report any errors or clashes. Everything seems fine, but I am unable to access from my iPhone which is the whole point of me trying to get this set up.

Any clues or anyway to test ?

k