Congratulations, well done

Thats an impressive update. Thank you very much for that. And my huge AppleScript-based workflow around DTPro does work as well - even somewhat faster. Or maybe it’s just the general beta-feeling.

Does anyone know if it is possible to have DTPro 3 OCR any new PDF automatically? Just because it got so much faster than before I was wondering if I could switch from my current external OCR-and-put-the-file-in-inbox solution to DTPro only. I tried it with folder actions, which works most of the time, that is until I scan a lot of documents in a row and the previous script wasn’t finished with the last task.

You could use a smart rule (see sidebar) that performs “OCR > Apply” on import and uses the conditions…

Kind is PDF document
Word Count is 0

1 Like

Apologies for jumping in here – but cannot get this to work.
Initially, with the log message returning the “Info” as “No Text” – which is kind of the point – I tried to manually select the PDF, and OCR it.
It then prompted me to download the AbbyyFineReader engine, which I did.
Following a restart of DTP3, I am still met with the same error in the log message – manually selecting the PDF and OCR’ing it, works as expected.

Below is a screengrab of the rule. Any suggestions?

Does it work after dragging & dropping the file onto the smart rule?

Just tried that, and yes – it triggers the OCR when dragged & dropped onto the smart rule.

Edit: By the way, I’m getting the file into DTP3 by means of a Folder Action, and the “Devonthink – Import to selected group.scpt” [figured I would just make that clear].

1 Like

That’s probably the problem - scripts don’t trigger smart rules (as smart rules can execute scripts on their own and as this would make the results of scripts unpredictable). You could try to index the folder instead.

Ah - thanks for the clarification.
No major issue, if I want to get files into my DB to auto-OCR, then I will import them from inside DTP3.

As an aside, doesn’t appear to work when I use the Sorter either, for presumably the same reasons you highlighted above.

That works really great, thank you. One minor issue - the original imported file gets deleted, which is what I want, while in the database the record remains. But since the file is gone it points to nirvana (meaning: it says ‘file does not exist’ and added the endless path where it used to be)

And found a solution for that - just add a delete action into the smart rule…

The original item was imported or indexed? And it was deleted by a smart rule or due to the settings of Preferences > OCR?

Imported & OCRed using a smart rule. In my settings I have “Delete original” checked in the OCR settings. But I found a solution, see above.

This shouldn’t happen but I couldn’t reproduce this so far. A screenshot of the smart rule would be appreciated.

appending ‘move to trash’ resolves it.

This occurs if you are explicitly choose an output format for OCR, like To Searchable PDF. If you choose Apply, the original file is deleted.

Actually “Apply” updates the item, it doesn’t create a new one (like OCR > to searchable PDF does) and delete the old one.

This is the product of using the To Searchable PDF option…

So the original was deleted from the filesystem, but the reference in the database wasn’t removed.

Now I get it, thank you. I just chose “to searchable PDF” because it seemed more obvious. And it is the way the toolbar button is working.

It’s definitely a bug, I’ve forwarded this.