convert back from App Store version

I’d like to convert back to the DT Store version from the Mac App Store version - how do I register the license? (it isn’t recognizing the receipt # as acceptable). Thanks! Keith

My understanding is if you install it over the MAS version, the registration will be automatic. It will show a generic license info pane, so it will not be personalized for you.

I’m not sure I understand.

I bought mine from the Apple Store and I didn’t get an update on the App store at all just now. I’m still running 1.4. Is 1.5 coming out in the App store soon, or does this version signify some sort of change that I have to install it from the downloadable at Devon’s web site?

Version 1.5 will be also available in the App Store soon (depending on Apple’s notoriously slow reviews). Or you could download the trial from our website and replace the version purchased in the App Store with the trial.

Thanks. I’ll wait for the apple store one though. It’s just easier. :slight_smile:

I’m unable to download from Devon Site: the download doesn’t start.
I don’t have problems to download devonthink’s updates, but the devonsphere express download doesn’t work…

Well, I have to complete my post: was unable to download from safari.
Works from Chrome.

Which version of Safari are you using? And are there any extensions which might cause troubles?

I’m using Safari 5.1.5

The extensions I have are:
Facebook Cleaner 3.0
Facebook Photo Zoom 1.1109.26.1
Social Fixer 6.602
Clip to devonthink 1.2.1

Thanks for the info! In case that you’re still not able to download the file, does it work after disabling the first 3 extensions temporarily?

Disabling extensions doesn’t change anything.

The problem comes only with the devonSphere express link: I tried to download the other products and it worked (redirected to….), but not for DEVONsphere…

Anyway I managed to get it via Chrome.

Hope it helps.


I also checked from here. Maybe there was something “stuck” in your Safari’s cache that prevented the download from commencing.

You got it!
I emptied my Safari’s cache, and the download is ok now!
Hope it will helps some users.
Thanks for your work