Crash on PDF import

Is anyone else experiencing crashes when importing PDF’s since installing Leopard? I can’t seem to find a way round it. I’m trying to import a 228k PDF by dragging it into the appropriate folder in DTP Office and I get the pizza of death. Same thing happens when I use the File> Import> Files & Folders route.


Do you use ShapeShifter?

No, not Shapeshifter. The only Unsanity product currently installed is Application Enhancer 2.0.3 which Unsanity says shouldn’t be causing any problems.

Please send an example file to our support address and we’ll check this over here. Thanks!

I’m also having trouble importing .pdfs at times (DT Pro Office current release on Leopard). Out of 1200 files imported (or indexed - same problem) DT hangs on a couple. One is a large file - 3.3 MB, the other a very small scan of a brochure. Trying to bring these into DT causes it to hang and requires a force quit.


Can Preview open those PDFs? If so, can you make a tiny annotation and save the PDF. Now can it be imported by DT Pro?

Yes, Preview will open the .pdf. I added an annotation as suggested and saved. Tried to import into DTPO and got the spinning disk of death. Had to force quit.

I’m going to assume that there’s something wrong with this file and not DTPO.


Precisely my experience. There appears to be nothing wrong with the files - they open just fine. The hangups appear to be on particular files, one about 3MB the other less than 1 (two separate approaches used: import and drag, so it hangs on two different files because the drag was meant to be incremental).

A user has sent as an attachment a PDF that fails import under DT Pro Office 1.3.4, running under Leopard 10.5.1.

I’ve confirmed that this file locks up DT Pro Office, and forwarded it to Christian for evaluation. If this happens to you, wait to make certain that the application is truly hung, and use Force Quit. No damage should result, as nothing is being written to disk to change the database. But it’s a good idea to run Tools > Verify & Repair after relaunching the database.

I’ve imported lots of PDFs without running into a problem, including a good many “printed” to the database using the script under the Print panel.

Looks like a Leopard PDFKit bug that may be triggered, perhaps, by a particular font , character or image type.

The example file is PDF version 1.4 and was produced by pdfeTeX-2.21a. The content creator was LaTeX with hyperref package. It contains a number of special characters and images.

Workaround: I can successfully import that problematic PDF by changing DT Pro Office Preferences > Import > PDF & PS – Index: from Use PDFKit to Use built-in pdftotext. So try that if you encounter this problem.

I still get hangs when trying to import the same set of pdfs after the 29 Nov update to devonthink pro office. I’m trying to import a whole batch of pdfs, so rather than finding each weakest link and dealing with it separately using PDFKit, I guess I’ll have to wait for a fix.

Chip, just to clarify. I’ve left my DT Pro Office preferences set to use the built-in pdftotext indexing mode. It is working fine for PDF import and indexing.

It’s not necessary to switch the Preferences setting back and forth for individual PDFs. Just leave “Use built-in pdftotext” checked and you won’t have the problem you encountered.

Yup, that worked. Thanks!

According to Apple, the 10.5.6 System Update issued yesterday contains Security Update 2008-008, which may have corrected this issue.

I haven’t tested the new functionality yet, either using Devonthink Pro Office’s Rebuild Database command or by doing a manual import of PDF files containing corrupt embedded fonts, and watching during import for a system hang/crash that forces a reboot. Nevertheless, here’s an excerpt from Apple’s discussion of this issue:

Updated: December 15, 2008
Security Update 2008-008 / Mac OS X v10.5.6

CVE-ID: CVE-2008-4236

Available for: Mac OS X v10.5 through v10.5.5, Mac OS X Server v10.5 through v10.5.5

Impact: Viewing or downloading a PDF file containing a maliciously crafted embedded font may lead to a denial of service

Description: An infinite loop may occur in the Apple Type Services server’s handling of embedded fonts in PDF files. Viewing or downloading a PDF file containing a maliciously crafted embedded font may lead to a denial of service. This update addresses the issue by performing additional validation of embedded fonts. This issue does not affect systems prior to Mac OS X v10.5.