Custom metadata not available

I tried that just now, the results were a bit peculiar.

  • Stopped both DTs
  • Removed both plist files
  • Restarted both DTs more or less at the same time.

The result of this was that machine 1 showed the full defaults, and briefly machine 2 did as well. It quickly went back to the empty list, though.

That situation seemed stable, until I did something on machine 2 that required a sync (I categorised a document from the global inbox to another database) after which machine 1 went back to the empty list as well.

1 Like

I spent some more time fiddling around with this and managed to find something that works for me.

I first tried:

  • setting sync to “manual” on machine 1
  • shutting down just machine 1’s copy of DT
  • removing the plist on machine 1
  • starting DT on machine 1
  • adding a new custom metadata item “Test” on machine 1
  • setting sync back to “automatic” on machine 1

My theory here was that the introduction of the non-default custom metadata would help things sync properly. That turned out not to be correct: after things stabilised I ended up with just the “Test” item on both machines.

Looking at that entry in the plist, I noted that it had a “date” key the default items didn’t. So I went through the process again with the added step of adding a “date” key to the default items as well.

That fixed the issue for me: I have identical lists on the two machines (except for enabled/disabled state, which appears intentional) and I can create and delete my own entries on either machine and the modified default items are never deleted.

I guess the underlying issue comes down to distinguishing a default metadata item which is missing, and one which has been affirmatively deleted. Some sort of tombstone for deleted items might be worth looking into.

1 Like

One issue is caused by the default definitions as they’re not handled like custom definitions, the other one is that the CustomMetadata.plist file was deleted but definitions should only be removed via the user-interface. However, we’ll try to improve this in upcoming releases.

I’ve been running into this problem as well for the last month or so when I first started playing around with custom metadata. I just want to clarify that you added the line circled in red to the other, default metadata definitions?

When I do that, starting DT on Machine 1 again, clears all the custom metadata definitions out…

When you do what specifically?

When I add the <key>date</key> to the other entries in CustomMetaData.plist as iay did above )if I’m understanding their instructions correctly).

Why are you manually editing the property list?

For all of the reasons in the thread above.

The first time I went to set up custom metadata, the defaults weren’t there. On another thread a month or so ago, the solution was to delete the .plist and DT would recreate them. It did. But as soon as I sync, they all disappear. The only ones that stay are ones I create–any default, even if active and attached to records, disappears as soon as I sync. Searched more, found this thread, so tried the solution posted by iay last August, but still losing them all as soon as I sync…

Just quoting and responding to say I have just experienced this after purchase today and direct sync today. Same result.

Welcome @happycatmachine

As soon as you direct sync with… what?

Direct sync is bonjour according to the help files that DT comes with. It’s DT’s terminology. Two Macs and an iPad though the iPad had not entered the fray before I lost all of those metadata examples. The problem is exactly as described above.

No worries though, it’s easy enough to create my own.

  • Were you importing a new database to the second Mac?
  • Or were you syncing with an existing database after having added custom metadata to files on the first Mac?

Thanks for the effort to delve but I’m not really looking for a solution here. It’s not a problem because I can add my own custom meta data. I will list the exact steps I took since they are easily remembered and it was a clean install just yesterday.

  1. Purchase upgrade to DT3Pro
  2. Download and install DT3Pro on Mac A
  3. Enter registration info (Mac A)
  4. Explore a bit, I did not migrate my old DT2ProOffice database over as I hadn’t used DT in years anyway and I wanted to start fresh. This is where I saw the ‘sample’ list of custom meta data.
  5. Created a new database
  6. Indexed a folder of PDFs, roughly 600 or so that I’ve curated over the years into that new database
  7. Read about synching in the help and in the TCODT book, decided I wanted to Import rather than Index.
  8. Deleted the aforementioned database (not necessary but I wanted to start fresh)
  9. Created a new database and imported that same folder of PDFs
  10. On Mac B I downloaded and installed DT
    Note: I did not register this copy until later in the day because I forgot to, so it was essentially running as DTServer for a while (this is not the serving machine, just that it was a DTServer install rather than a registered DTPro install). This shouldn’t matter but the devil is sometimes in the details.
  11. I turned on DT>Preferences>Sync>Bonjour Options…>Enable Incoming Connections on Mac B in error. Again, this should not have made a difference.
  12. I turned on DT>Preferences>Sync>Bonjour Options…>Enable Incoming Connections on Mac A (which was to become my serving Mac, so to speak)
  13. On Mac B I selected Mac A as the location of the database I wanted and chose my newly created database to Sync.

NB: I started this synching process before the indexing of the PDFs on Mac A was finished. I stopped the sync and waited for the indexing to finish and then continued. In fact, if memory serves me correctly, no sync would happen until the indexing was finished on Mac A anyway.

Once I got my synching working the way I expected it to I set out to explore in more detail the new (and old, it had been a while since I had used DT) features in DevonThink. It was then that I thought that I’d like to store some additional information about these PDFs and went to look at the DT>Preferences>Data screen again and found that the Custom Metadata list was empty (no more grey sample items).

It was at this point I googled the issue and found this thread a posted.

Hope this information helps you :slight_smile: Again, I don’t need a solution because I don’t need sample metadata to build my own. I just hope my own custom metadata doesn’t mysteriously disappear at some point. Given that I’m in sync with all my installs I’m not too worried.

Thanks for the thorough post and understanding attitude. Both are appreciated :slight_smile: