Cut and Paste text from DevonThink 3 note

I cut and paste two pieces of text from a DevonThink 3 note to a data input form for an ID and a PW. I didn’t give the data pasted a second look thinking that it must be fine. When submitting the form, it wasn’t processed but there was no error to say what the problem was. I then discovered that both pieces of data paste were different from the copied ones, expanded with additional characters or changed but somewhat similar.
Anyone knows why? One piece of data for example:

Copied data: 924522114937
Pasted data: 492542521211449937

This is not a one time issue.

We’re not aware of such issues currently. Additional details like what was selected in what kind of document and where exactly did you paste it would be useful.

The copy and paste was from a pdf document previously dragged into DevonThink 3. In DevonThink 3 it is listed under Kind as PDF+Text. The data was originally recorded in Evernote but I cannot remember if it was exported directly or saved as a pdf before dragging it into DevonThink 3. Going further, I tried other copy and paste from other .pdf saved from PDFpenPro and they seemed to be OK. But with another .pdf I am sure originally in Evernote I had the same corrupt pasting results. See attachments. As long as I know not to do a copy and paste from DevonThink 3, I think I should be OK. I was pasting to a commercial software called Ftax which a UK taxpayer completes his Tax Return and submit to HMRC online. Don’t think the issue is with them as after manually correcting the ID reference and the PW, it went through OK.

PDFPen doesn’t use Apple’s PDFKit.
What do you get when using Apple Preview?

I used ForkLift (previously Path Finder) for most of my file management purposes and only occasionally Finder for other tasks which cannot be done using FL or PF. No issues using these two apps.
Back to your Q, clicking a .pdf file and in Preview mode Column View will show a large thumbnail of one page of the file which is sufficiently large enough to be read and scrolled through as well if given sufficient screen space. Other views do not show the contents of the file. However in Finder > Quick Look the pdf document can be viewed perfectly.

I mean what happens when you try to copy text in the same document in Preview and paste it in this other app?

I don’t understand what you are asking … “copy text in the same document in Preview” - which document? and “paste it in this other app” - which other app?
The earlier attachments re Bees Collectors were from DevonThink 3 to MS Word 365. This is run on a Mac on Monterrey.

  1. Open the same problematic PDF in Preview.
  2. Select text as you did in DEVONthink.
  3. Copy it.
  4. Go to Word.
  5. Paste as you previously did.

attached screenshot

  1. Is copied and pasted from DEVONthink to Word.
  2. Is copied from Preview and pasted to Word?
  3. Is opened where and pasted into Word?

The screenshot is that of a Word doc.
Therefore the answer to your Q

  1. Is copied from DevonThink 3 and pasted to Word
    2 is copied from the DevonThink 3 Preview Pane and pasted to Word
  2. click open DevonThink 3 document, copied from the opened document and pasted to Word.

Again, open the PDF in Apple’s Preview application and try the same copy and paste.

Just in case I didn’t do what you wanted …

Right click on Doc > Open with > Preview
Copy and Paste two items of text
Results see attachment
2022-01-27_13-31-16.pdf (40.4 KB)

Thanks. And that also is not copying and pasting only the selected text, so it’s not just a DEVONthink issue.

Use DEVONthink’s Data > Convert > to Plain Text command on the PDF and view the text in the new document. What do you see?

Selected document and applied Data > Convert > to Plain Text
Nothing changed visually. Tried Copy and paste selected text - yielded similarly corrupted results.

I have just met my deadline for online filing of Tax Returns and will have a little time reconstructing the problem from moving stuff from Evernote to DevonThink 3. Don’t think it is a PDFpenPro problem.

Further to my last response, I have had a chance to reconstruct and experiment on what works on porting Evernote notes (free version) to DevonThink 3. The attached Word document will explain all so no need to expand what I did here.
Notes from Evernote to DevonThink 3 issue.pdf (138.1 KB)