DA bombing as soon as it starts

I had Da set up to start upon login. The second or third time I started the machine, Da would bomb upon start. After that, any intent to run Da again produces an immediate bomb. How can I reset Da so that I can diagnose it any further? I have only one search defined (deep Internet-wide), and I have deleted a few documents out of the results (several thousand pages)

Configuration: dual-processor 2.5 Gz G5, 2.5 Gb memory, dual-disk array

All other applications run without a problem, and Da is the first app to bomb immediately upon start. I’ve read some references to producing a log file, where can I find it?

Any help will be extremely appreciated.


What operating system are you using, and what version of DEVONagent? (Based on your other posts, I’d guess at least 10.3.9 or 10.4.x, but I generally ask this question for the type of behavior you are seeing.)

I assume you are a registered user of DA, so it’s not refusing to launch because the demo period has expired? You should see your registration .plist file at /YourUserName/Library/Preferences/. It’s the file named “com.devon-technologies.agent.registration.plist”. If it’s missing or corrupt (and you’ve been using DA past the demo period), that could be the problem.

Try deleting DA’s preference file. You can find it at /YourUserName/Library/Preferences/. It’s the file named “com.devon-technologies.agent.plist”. It’s possible that the prefs file may be corrupt, or that you’ve set preferences to load an archive file (or set) that may be corrupt. Try relaunching DEVONagent. If it launches OK, one of those possibilities were the problem. Set your preferences as previous, close and relaunch. Problem? Perhaps you can zero in on the culprit. If DA crashes when you load the Archive, you will probably need to repeat the searches contained in it.

It’s possible that the DEVONagent program has become corrupt (although I’ve never seen this myself). Try downloading it again.

If none of the above work, it’s time to send a request to DEVONtechnologies Support. In your email, document the behavior you are seeing and attach a copy of your DEVONagent crash log, That can be found by opening the Console utility application. Click on Logs > ~Library/Logs > Crash Reporter > DEVONagent.crash.log. It there are a lot of them, scroll down to copy to the clipboard one or two of the most recent reports (the reports start with a ****** separator). Paste this to TextEdit, save it, use the Finder to make a Zip archive and attach that file to your email message.

Hope this helps.

Thanks, Bill. I am using Tiger, latest version. I am a registered user. It was not the .plist file (kept bombing). Only re-installing the program solved the problem, which is a bummer because of the loss of existing preferences, but at least I am running again… If it keeps hapenning I will send the log to the Support group.
Thanks for your suggestions

Haven’t used Da for a while… But now that I tried, I am still getting bombs, albeit with different circumstances: start a search for a single word, “telelogic”; internet-wide, fast search, works OK. Now, I ask it to run again, to follow links (any depth produces bomb), to apply the usual three filters from the options panel, and Da bombs after a a number of results have been retrieved (number of them depends on depth of the links followed).

Tried deleting prefs file, same result. Same with re-installing.

Running Tiger, 2.5 Gb memory and plenty of disk.

Update: Removing the “Junk” filter, which I had applied before, still gives me a bomb. In other words, as soon as I ask Da to follow links, it bombs. Any clues?

The best way we can help you is if you follow Bill’s advice related to sending an email to the support address with the crash log included. Crash logs will help us to determine the problem a bit faster.