DA browser downloads not downloading

Hi -

On my dual 1.8 PowerPC Mac 10.5.1 I am running DA 2.3 . When I open up the DA browser and go to a page with links to PDF I want to download they show up in the tray on my DA browser. I then select them and click on “download”. The DA download window opens up and then they just sit there. I even let it run overnight and it eventually downloaded a couple of 10k files in the list, but the rest just sat there. I tried to manually download the files in case the servers were down, and I had not problem accessing the files directly that way. I restarted DA and tried again, same results, nothing (for all practical purposes) will download. I tried this from the DA browser on a number of pages with the same results.

Any ideas?


R. Joe

Did you start the downloads queue via the contextual menu or the button in the lower right corner? Because by default the queue is not active.

I used the button in the lower right corner.

When nothing downloaded I tried highlighting an item in the download window and right clicking on it and then choosing “retry”. I also tried “enable” then “retry”.

Does that help?


That’s indeed strange. Do you have an example for me not downloading? Does Safari download the item? Note: You can select an item in the download manager and press Cmd-C to copy its URL.

There are no problems downloading the files any other way, even if I am in the DA browser I can right click and download the files with no problem.

I followed some ideas on another thread and deleted my caches to see if that helped, but no change.


R. Joe

Just send me a URL and I’ll check this over here - thanks!

Here is an example

it downloads fine from all of my other browsers (Safari, Omni Web, FireFox), but not from the DA download window.

geo.uni-frankfurt.de/ipg/ag/ … el2003.pdf

Thanks for your time.


Strange. I could download this without any problems.

I was going to attach a graphic of what my window looked like, but I did not see how to do that in this forum.

R. Joe

Joe, you could send an image in a message to Support.

I sent it over.

R. Joe

See my solution at:


my problem is exactly the same as yours but the link to the solution doesn’t work!
did you figure it out?

Here’s the link for the new forum: