Data loss - .rtf files suddenly blank

Hello; all the .rtf files within the sub-folders of one specific folder have been completely wiped clean. Their neighboring .txt, .md and .pdf files are alive and well.

If it wasn’t for a fluke in DTTG sync, these documents would have been irretrievably lost: because I never figured out how to get my ipad to sync consistently, it still had my files as they were from a month or two ago, and I immediately sent them to myself. And they collectively reflect a decade worth of education and training. Of all the notes I could have lost, these would have been the most devastating and crippling to have lost.

I haven’t found much in the way of similar experiences from others. I have attached a screenshot showing what the blank rtf looks like in DT; you can see they all have a non-zero size, but absolutely zero content. When I try to open in text edit, or export and then open, they remain completely blank.

I want to keep using devonthink, but I’m not sure how safe it feels anymore. And yet, nobody else seems to report anything similar? Is there any plausible explanation for what I happened? I can handle using software that does problematic things in predictable fashion; but when I don’t even understand the underlying issues, I get very uncomfortable. This is the kind of experience that makes one reflect true impermanence of digital notes, on the contingent existence of electrically stored data.

Any help much appreciated,
Kind regards,

Welcome @sean.albo

Have do you done File > Verify & Repair on the database?

Hey, thanks for answering/checking - tried, but no luck in restoring the content of the notes. When I execute verify/repair, the activity log shows “successfully verified”.

That sentence should probably make you think long and hard about your backup strategy. I hope you get to the bottom of what caused this (and let us know; it’s bizarre the files should be non-zero in size but empty; perhaps try viewing them with cat from the terminal) but even more I hope that it makes you realise you need a backup strategy suited to the value of your data. If it’s of any value to you, I posted about mine here and have since added monthly backups to Blu-ray.

The need for a backup strategy is independent of the software you use; none is guaranteed to be fail-proof under all imaginable circumstances.

Yep, that’s exactly the outcome. I was a bit too cavalier and patient - I knew I needed a strategy, but I kept putting it off. Auspiciously, I haven’t been able to reconnect my new device to old backup on time machine capsule, and so I suddenly felt very vulnerable, and then this happened. Will definitely look at your approach, thank you for sharing it.

edit: I wonder if the lazy approach is a vestige of a past in which our data was hard-written into the objects around us… because the logical approach, a kind of upkeep for the benefits of our digital realities, really is to have multiple backups, but somehow it doesn’t provoke immediate action, despite the potential severity of a single hiccup.

Yeah, I do realise I’m too late with my rather obvious comments :see_no_evil: (horse, barn and bolt come to mind). I experienced the same with Time Capsule some while back, which was when I realised I needed to act.

I’m happy you’ve not lost anything.

I have experienced DT as rock solid. If you do for whatever reason decide to switch to different software, make sure you understand how that software stores your files and how you can retrieve them if the company fails. DT stores files in their original format in a database which you can access from Finder. So getting your data out of DT will always be possible (even if it might not be convenient). Not all software works that way.

1 Like

Maybe. I was always worried what would happen if my apartment burned out, though. I actually feel my data is safer today. That’ll change if I ever “lose” it through hacking, malware or whatever, of course.

The process by which I retrieved my files from the ipad DTTG was ridiculously quick and easy. At that moment, my anger at the situation turned into marvel that it could be such a good piece of software. Just to be able to select 100s of files within a few minutes, export them as you said.

I really DON’T want to stop using DT. Maybe with a robust and reliable backup strategy, I will be less risk averse - especially since it seems such an unusual occurrence.

:+1:t3: Maybe others will post some suggestions as to what might have happened.

Is it only rtfs which have “failed”? Have you tried opening them on a different computer? Or as I said using an editor/viewer such as cat from the terminal?

It is highly abnormal and the only report I’ve ever seen. @blanc’s observation was my first as well - non-zero-byte files but no apparent content. And it couldn’t just be a matter of white text on a white field, as the Navigation bar is reporting 0 paragraphs, words, and characters.

If you have a broken file or two still, could you hold the Option key and choose Help > Report bug to start a support ticket and attach a few? Thanks!

PS: Yes, you should have a robust and reliable primary backup strategy in place, regardless of what apps you’re running. A good secondary, or even tertiary backup is also a good idea.

Yep, only rtf. Tried to open on No other device to try on for the time being. No luck with other devices, and other editors didnt seem to provide anything (though I didn’t try any terminal specific editors, not being familiar with any).

Will do, thank you very much for following up. I’ll make that support ticket (and some secondary backups as well :slight_smile: )

You’re welcome.

uhhh… did you ever use Dropbox? ever? because there isnt a day that goes by since i quit dropbox years ago that I don’t find an old folder that is either completely empty, or whatever file it was (or file type) are just blank, then.

i spent hours on the phone with a superengineer bossperson, and they said it was “a Google Chrome bug in the way it interacts with Dropbox.” Whatever THAT means didn’t help me, and I still feel like it had to be Dropbox, since the files were in Dropbox…lol

Also iCloud Drive reaaaally struggles to sync or load any file. well, it loads instantly with my fiber speeds, but they must have programmed a 10 or 15 second delay before it ever STARTS downloading.

But the thing is, sometimes Dropbox or iCloud Drive can’t finish. like, you know, when it brings your CPU up to boiling water temperatures, which iCloud Drive only approaches, while Dropbox ALWAYS did.

I wonder if you didn’t somehow get the rtf files started to transfer and then it got cut off and never was able to get any of the files? i mean, this is obviously a stretch of a reason, but i think that is even a lot more likely than Devonthink killing your rtf files… i can’t imagine any programmed thing of the sort that COULD do that in DT…

but - maybe u dont use either service! so i really dont know, but, there’s my two cents!


Welcome @thegoldenyellow

Thanks for sharing your thoughts.

Hey, thanks for asking! I did use dropbox at some point, but I never kept any of my DT files or databases in dropbox. They were always local on my computer, just in DT, and from there syncing out to ipad/iphone via bonjour, but literally ever other file that was also synced was untouched. It’s enough to make one believe in circuit-gremlins…

:man_shrugging:t2: well, at a minimum, you know this about dropbox and iCloud Drive, lol. good luck!

try to remember to post here something quick if you ever do figure it out? thanks!

with the now out-in-the-open invasiveness of our new non-DT oligopolarchy (?), our Big Tech Overlord Grandmaster Savior King Hero Role Model Freedom Loving Entrepreneurs (blessed be their names, their holinesses), my first guess would probably NOT be the circuit gremlins…

unless…wait… are you in… Tron?

:rofl: just being a goofball.
nice to meet you all. i have questions about DT, but ill make sure i post on relevant threads so i dont hijack this one.

1 Like

Be careful or you’ll be queued for permanent deresolution, per Sark and the MCP.



all i know is how much I want to watch whatever the heck THAT cartoon is. :laughing: it sounds like a fun watch once, even if it sucks. what’s it called??