Database changed to .dtsparse - then back to dtBase2 but still can't open it

Computer was on Mojave, and I had multiple devon think databases running Devonthink 3.61 now. (I was on an earlier version of Devonthink 3 but not sure which version.)

The database (Inbox-new) changed overnight to Inbox - New.dtsparse
Tried to open it but i could not
Tried to:
repair database,
rebuild database,
ran disk utility
Ran Malware Bytes - Clean
Running latest Devonthink now 3.6.1 (not sure which version of Devonthink 3 I was on when this first happened.
Updated to Big Sur 11.2Still can’t open database.

Now, the database shows as Inbox - NEW.dtbase2, but still can’t open it.

How can I fix this?

DEVONthink actually doesn’t change the extension. Was does the Finder show after removing the extension - a file or a folder?

It shows Devonthink Database Image.

Is there a way to get this back so I can use it? It happened to 4 databases.

I right clicked on it and got a bunch of options. One of them is, “open with”, but I have no idea what to use to open it.

Was this a glitch in Mac OS Mojave? I have now updated to Big Sur.

Thanks for your help. By the way, I have used Devonthink for many years now. Love it.

Thanks for the nice comments!
Hold the Option key and choose Help > Report bug to start a support ticket.