database file will not copy or back up

I’m using Carbon Copy to backup my entire User name all files etc. I notice it hangs on Devonthink/devon.dtBase-2 and will not copy these files or finish the backup script.

So, I tried to manually copy devon.dtbase to another folder. It will not copy. I get an error READ/WRITE .

I verified, and rebuilt from within Devonthink. At this point, I do not have a backup that predates this problem.

Any ideas how to un-corrupt this file?

Hi, Alan. We’re trying to take a little more time off during the Christmas - New Years period. At the moment it’s snowing outside and I’m about to go sit in front of the fireplace.

If you can send a message to Support, including any information you can think of about what might have happened, we’ll try to help.

What about your existing backup on the external drive? Have you tried to recover it?

Note: Before doing anything else, make a zipped copy of your current database, in case it may be possible to recover data from it. I would have recommended that before the Rebuild operation. Always quit DT Pro before making a copy, of course. A copy made while the database is open could have errors, especially if the database is in the process of writing something to disk and hasn’t finished.

I always recommend using Scripts > Export > Backup Archive occasionally, evan when routine backups are being made otherwise – and especially at a break time when significant modifications have been made. Backup Archive also verifies and optimizes the database, as well as producing current internal and external backups. I like to keep that compressed archive file somewhere else as an extra precaution.

Leopard’s Time Machine impresses me. I’ve experimented with recovering databases from their previous states in time. I haven’t experienced any quirks. But I still run Backup Archive at times because I value it’s “housekeeping” routines – and for important databases I keep a DVD containing the compressed archives in a box at my bank in case anything were to happen to my computers – theft, fire or whatever.

Thank you Bill

I certainly don’t blame you trying to take some down time. Enjoy.

I will put together a more complete description of the problem and forward it to Support .

In the interim: I had made two zip archives during this incident. I run the backup script about once a week and keep a few weeks of archives. I don’t have any way of determining when this problem started but I don’t have a zip of the file that doesn’t have the error.

I don’t have an external backup because the file won’t write to disk or copy. It pays to look at those backup logs once in awhile I guess?

thanks again.

I weekly clone my entire drive to an external LaCie and an external WD (rotating backups) with CC3 without any file problems

Had you try to repair permissions on you internal drive using Utilities/DiskUtility or better on booting an the OSX DVD:

After this, try the simple-copy thing (I guess you copy to your external drive, right ?).
Despite DTP databases, do you face the same error when copying another document to the same folder of your external drive ?
And by the way can you burn the DTP db on a DVD ?

if “yes” with any other document, so I guess the problem is on your external drive’s side

if “no” with another document, but still “yes” with DTP stuff…
(1) repair disk from install disc … =106214-en
(2) run the fsck filesystem check procedure (same article)

And retry…

Post back
Regards and a merry Xmas !