Database gone

My main database is gone! It is no longer in the side-pane. When I try to open it from the finder, it opens another database.

Closed everything down properly last night. Tried rebooting DT and tried rebooting my computer.

Don’t want to go any further (rebuilding, restoring, etc.) with trying things without some advice.

Please help…

Unless you have inadvertently deleted the database file in the Finder, it’s still on your hard drive.

Did you try File > Open Recent > ?

Look in the Finder for a file with the name of your database and with the suffix “.dtBase2”. Odds are that it’s in your Documents folder. If so, double-click on it to open it.

Hi Bill. Those were the first two things I tried. As I said, in both cases, it is opening a different database.

I most certainly did not delete my database. It is still there in the finder but opening a different database entirely.

The key thing is that I did nothing unusual. The database was working right before I went to bed. I closed DT and shut down my computer and when I booted this morning, DT was one of the first things I opened.

By the way, when I look at the size of the database in question, it is very small…only 49kb.

This is my main database, so it should be gigs larger.

Just found it but it is opening up under a yet another database name. I have 6 or 7 databases. Most of them were open last night when I shut down. Now, they seem all jumbled up.

i.e. clicking on database ABC opens database XYZ.

Any further thoughts on this…this is my principal database and I currently cannot work without it. I back it up regularly but I still need a high level of confidence that the DT system is robust.

To open a database file, DEVONthink relies on the Finder to find the file and open it.

There are two possibilities.

  1. DEVONthink has gotten the databases confused, so that a command to open one results in opening a different one. I’ve never seen that happen and would consider it unlikely. Check the path to the database shown in File > Database Properties. I would suggest that you choose File > Open Recent, choose a database and see if it is indeed the proper one that opens.

  2. You’ve got an operating system problem. That sounds more likely, given that an attempt to open a database file from the Finder, as you said you did, resulted in the wrong database being opened. Suggestions:
    a) Run Disk Utility’s Verify Disk routine to check the health of your disk directory. If a problem is found, start up from the OS X install disk, choose Disk Utility and run Repair Disk.
    b) Run an OS X maintenance utility such as OnyX or C*ocktail and do a thorough set of maintenance operations including cache cleaning and rebuild your Launch Services database. It’s a good idea to run preventive maintenance on OS X periodically to keep your computer happy. Caution: Make certain that the maintenance utility used has been updated for the version of OS X you are running.

I ran a rather thorough maintenance with Onyx within the last 4 days. Just check the version and I was using 2.1.2 and the most recent version is 2.1.4. Rebuild of Launch Services was also executed during that time.

Note: About a week ago I changed the name of the my main database through Database Properties.

The bizarre behavior:

  • from database properties, I can see that my main database points to the correct file. Opened it via File > Open Recent. However, as stated earlier, it is not the main database that opens.
  • from File > Open Recent, I open the main database ‘by it’s old name’ and there is my main database and it points to the ‘old’ file name. It is named correctly.

Somehow the database names are all jumbled. Can I use Database Properties to rename them correctly and perhaps run Rebuild?

I guess I can run Onyx again afterwards or would that be better to do before renaming.

Changing the name of a database in Database Properties doesn’t change the name of the database file in the Finder; it simply changes the name displayed in open windows. DEVONthink still maintains the Path to the database under its Finder name, not the changed name created in Database Properties.

The name of a database can be changed in the Finder. CAUTION: Always close a database first, as changing the name of an open database can result in the database becoming incomplete or damaged. Note: If one has changed the filename of one or more databases, choose File > Open Recent > Clear Menu to wipe the now incorrect set of database names from memory. Then use File > Open to open your database and repopulate the list of recent databases.

Bottom line: Your databases were all there and functional.

I suspected things were not too serious but, not understanding DT’s inner workings, had to be certain before I tried changing names.

Thanks very much for the clear, concise, and prompt replies.

I downloaded and opened DevonThink 2.0. What I didn’t expect was that my DT 1.9.16 database would not open. In the instructions for upgrading, there was no warning or note of operations to be done before upgrading. In fact, it appeared as though no special precautions were needed.

The database has not disappeared. I reverted back to version 1.9.16 and everything was still there. I believe this needs improvement. I’ll stay with v1.9.16 until this is resolved.