Database in Use too frequently

I am a long time DT3 user. Version 3.5.2 - Mojave
I shut down every evening
On booting I get a dialogue box saying my Database is in use. Usually, not always, pressing cancel will either go to my database or let me go Open recent and open. That is bad enough
Sometimes I can’t open the database. I press “rebuild Database” it goes and tells me there are 4 or 6 damaged records. Sometimes it will start then, other times and following support instructions I have to use terminal and import database.
That works for a while and then we are back at the start.
This isn’t the way I expect this software to work and I shouldn’t have to go back to support repeatedly
Am I the only one with this problem? Has someone solved it without recurrence?

Thank you

Do you mean you shut down your mac or DEVONthink?

If you mean booting your mac: Did you try it without automatically launching DEVONthink?

I never read about “damaged” records. Do you mean missing files?

In DEVONthink 2 I’ve seen “database in use” quite often, but not in DEVONthink 3.

  • What database are you referring to?
    • If it’s not the Global Inbox, where is the database located - the file path on the machine?

Let me try one by one:
@pete31 I shut my Mac down.
I tried with and without automatically opening DEVONthink. No difference
Yes, I guess it says missing files
@Bluefrog: If I left arrow from Devonthink I got to an empty In Box
The database is in my Documents Folder: user >> Documents

And are you using iCloud Drive with your documents inside iCloud Drive? If yes, you’ve got the problem.

It is not recommended to have databases inside any cloud. Common place for the database is in your ~/Databases folder.

1 Like

@rfog I correct my earlier statement. My database is in ~/Documents/Devonthink Databases.
My ~/Databases is empty.

Ok, and you have enabled sharing Documents across iCloud Drive?:

(Sorry, my Mac is in Spanish, but option is in Settings -> Apple ID -> Options in iCloud Drive selection, and your text should be not much different than “Documents and Desktop folders”).

@rfog No problem. I speak read an write Spanish. No, Carpetas Escritorio y Documentos is unchecked - on purpose. My reading has discouraged that.

Please post a screen capture of the warning you are getting. Thanks.

This is what I got this morning. I pressed “cancel” and ent to the dtabase. When the stars are alligned wrong, nothing improves and I have a hard time launching my database

Hold the Option key and choose Help > Report bug to start a support ticket.


Thank you


No problem.

yes I see this often

This should only happen if DEVONthink or the computer crashed or you used force quit.

I get this too.

Additional details would be useful, e.g. does this happen after quitting and restarting the app? Restarting the computer? Updating the app? Or updating macOS? A crash of the app or the system? Force quit? Etc.

I get this probably 1 of 3 times I start the app, regardless of having closed properly.

Please choose Help > Report Bug while pressing the Alt modifier key and send the result to cgrunenberg - at - - thanks! Maybe there are some crash logs.

As C. Grunenberg says, this happens to me only when the Computer crashes or freezes, which has been happening frequently lately.

1 Like