database in use

I’m getting this message every time I try to open my primary database. It says it is already in use. This after shutting down the program and even restarting the computer. I can hit ignore and the database will open, but why am I getting this message???

I have also lost my global inbox. All I have under Globals is the Trash. So everything stored in my global inbox is gone.

Hi, Alexandria.

Common causes of this message are happenings such as the existence of a second DT application trying to access the database; system errors or a Force Quit that threaten the integrity of the database; use of a synchronization system such as DropBox and failure to close the database on the first computer before attempting to access it on the second computer (in this case, pressing the Ignore button could damage the database).

Make sure that you do not have two DEVONthink applications capable of opening the database in your Applications folder.

Run Tools > Verify & Repair to check database integrity.

If there are no errors, or the errors are repaired, Quit DT Pro/Office 2. In the Finder, Control-click on the database file and choose ‘Show Package Contents’. If there’s a lock file visible, delete it and close the folder.

Launch DT Pro/Office 2 and open the database. Fingers crossed, there will be no warning message.

Hi Bill,

I checked and do not have a second application capable of opening my database. There is only one copy of DT Pro on my computer and nothing else. I may have used a force quit on the program a while back, can’t remember. I use no sync system at all. I only have one computer and that is the one I’m on, and I shut it down and booted it back up and still got the error message. No lock files. I did have some orphaned files when I did a verify/repair on the db, fixed that, still getting the error. Finger crossing apparently did not work either.

I also still have no global inbox, and there were a lot of files in there I need for my research.

What do you think is going on and how might I get things working again. And how might I recover my lost inbox? Thanks!

PS, something did change slightly. I still get the error message, but now if I hit OK, it still opens and if I hit Ignore, my global inbox appears. It does not appear if I hit OK. Definitely weird behavior in my book. I plan to get everything out of my global inbox and archive my files since I don’t know what is going on with DT.

OK I have to confess that I’ve had this happen from time to time, but there is no external situation or circumstance that caused it, afaik, as in the scenarios that Bill described. I’ve seen this pop up before in discussions but I’ve kept quiet because this behaviour is not at all reproducible for me.

I’m wondering though, if it might have something to do with feeds updating in the background without the user knowing that some activity is taking place, somehow leaving the db in an unsettled state upon quit?

There has never been a circumstance, upon seeing this alarm, where I have an idea that ‘such-and-such’ caused the behaviour.

But it has only happened six or so times since the pb’s began, with no harm done, so I haven’t fretted about it.

It also used to happen to me once in a while, but when I wrote the original post it was every time. And my global inbox had disappeared no matter what I did. I did all the things Bill suggested, it did it again when I reopened the db.

BUT, I just tried quitting the program and reopening the db, and it did NOT do it! The only thing that changed was that the db repaired some orphaned files. Weird thing is it did it again right after doing that as well until I hit ‘ignore’ instead of ‘okay.’

But, since hitting ignore instead of okay, everything is now back to normal and no error message. So the problem is solved, but not answered! As far as I’m concerned, this is glitchy behavior. Why did my global inbox disappear and then only reappear after hitting ‘ignore’ after repairing the db? Why did the error message appear after repairing the db at all? It should not have.

Anyway, it’s done for now, hopefully for good and it will go back to happening once in a blue moon and I too will ignore it. Even though it does give me pause and I am a little less confident in DT’s stability, which I’ve never before had reason to doubt. Perhaps it’s good to be a little more cautious, eh? Even with Dt.

Thanks Bill for your help and cyol for your comments.

Just checked those orphaned files and they were basically junk! I think they were sites I visited while browsing in DT, and were nothing I wanted to keep or attempted to capture. So I have no idea where they all came from. I’ll keep an eye on this when browsing in the future to see what happens, but it was a strange thing and doesn’t seem like expected or normal behavior to me. But I’ve cleaned all of them out and my db seems okay for now.

The same thing is happening to me now. Is there any more information regarding this issue? Perhaps a workaround of sorts…

I’m unable to see my global inbox. I’ve tried everything, short of reinstalling DevonThink Pro.

Add me to the list of people stuck in this problem. I’ve tried all the fixes suggested above with no luck.
Any new suggestions welcome.
@TylerGred: did you try reinstalling? Did it work?

I get the same warning often enough, but I have been ignoring it with apparent impunity. Will I suffer for my complacency?

I’m also having the same problem, it seems the program is silently quitting, without telling me. Then the next time I want to add something I think its the Sorter that is still awake and that launches Devon Think again.

I’m running 2.0.9 now but I had the same problem with 2.0.7.

Its not saving any logs, as far as I can tell, when it silently quits, or I would attach it.

My use case usually involves saving web pages as I surf for review from Devon Agent and reviewing them in Devon Think - annotation later.

Any ideas? I like the application a lot…

Oh, also, sometimes it also complains that “Take Rich Note” is not available, and then I have to restart the entire machine to get it to save stuff in Devon Think from Devon Agent again. But that’s hard when I have lots and lots of windows open in DevonAgent.

I’d send you a log but also now it appears to not be saving them. Maybe I changed something by mistake. I turn off services that I don’t think are necessary and sometimes they are things the system wants. What’s the best way to get a log capture of the possible causes?

The ‘in use’ message will appear after any event that results in a database not having been properly closed after the last access, including a System or application crash, Force Quit, forced shutdown of the computer, severe voltage fluctuation or power outage, etc.

We strongly recommend running Tools > Verify & Repair to check database integrity after seeing the ‘in use’ message.

The DEVONthink crash logs will be found at ~/Library/Logs/CrashReporter/. If you are getting frequent application quits, that’s not normal and you should send a copy of a recent crash log in a message to Support, including any information about what you were doing at the time of the crash/quit.

If your computer is acting flaky, a restart may help. I run an OS X maintenance utility every few weeks to keep the operating system clean and efficient. I use C ocktail, but also recommend OnyX (donation-ware). Be sure the utility has been updated for the version of OS X you are running.

I have this problem too. I have a MacAir runninga trial of DevonThink Pro Office. I checked to make sure I only have one instance of DevonThink Pro Office on this computer. I don’t use DT on any other device. I have one database. There is no .lock file in the package.

I was using DTPO, and added a new RTF file to an existing group. As I was naming it, DTPO froze. My other applications were running fine though, so I let DTPO run for a while but it was the application was still unresponsive, so I ForceQuit from the Dock.

The first time I tried to launch DTPO, it said other instance of DT is using the database or DT was forced to quit. I tried Ignore, but it still didn’t open the database.

Now, I tried to launch DTPO again, and it said that the application cannot be opened “-600”.

I don’t know what’s going on. Please help?

I have found this error happens frequently and there is no real cause. Some things are not explainable. I just continue on ignoring it altogether and it’s fine.

Why it happens who knows. Should it happen. Of course not. But as I said some things are not explainable.

Dt’s AI can’t offer an explanation? :mrgreen:

Since updating my DVPro to the latest version I lost my database sync on Dropbox. All my folders are gone and the only thing left is the inbox with all unsorted messages. I have DV on my desktop and my laptop but am not using them both at the same time. This is causing me great concern because I can’t find critical files or registration info on my software…

Did you place your DEVONthink database in the Dropbox folder? That can damage a database, in in some cases cause unrepairable damage. Or did you use DEVONthink’s Sync procedure with Dropbox, which does work?

Do you use a backup system, such as Time Machine, for your data?