database locked?

Long story short - I had a hard disc failure and replaced the HD. Reinstalled DTPO. Transferred a copy of db to doc folder. Now when I open DTPO I can open my db and view it but not add anything or edit. Looking at db properties shows the lock closed but grayed out. In finder I do have full permissions for the db file. What can I do to again work with my data - thanks

The file permissions of the restored backup seem to be “read only”, therefore all commands modifying the database are disabled. You might check the permissions via the Finder, especially ownership and write access.

I did and have read write permission for the database

Please open the database package’s contents via the contextual menu of the Finder - what are the permissions of the .dtMeta files and of the Files.noindex folder inside the package?

within Files.noindex, Backup.1, Backup.0 and Backup all meta files show me as having read/write permission
thanks

Are you able to use a copy of the database created in the Finder?

when I attempted to make a copy I received and error message that I did not have sufficient permission so a copy was created that had 0 KB of data - thanks

Remove the .dtBase2 extension from the database, open the Info panel in the Finder for it, choose the right permissions & ownership, apply them also (!) to the enclosed items and this should fix the problem. Finally, add .dtBase2 again.

I am sorry but I do not know how to remove the extension. If I edit the name it replaces the extension automatically - thanks

If you cannot copy the database package file or rename it that sounds like a Sharing & Permissions error. I’ve played around with a dummy database, doing all kinds of strange things to permissions within its contents, and I can still rename the package file if I’ve got read & write permissions at that level.

QUIT DEVONthink. Select the database file in the Finder and open the Info panel. Under the Sharing & Permissions area it should say “You can read and write”.

There will be a username below that. If it is your username it should be followed by ‘(Me)’ and should show ‘read & write’ permissions.

I don’t know all the things that might have occurred, as you had a hard drive failure, replaced it and installed everything on the new drive.

Try this: Click on the Lock icon in the Sharing & Permissions area of the Info panel and enter your administrative password. The lock will open and you will be able to edit permissions.

Click on the ‘+’ button, then click on ‘Administrators’. This will add to the list of authorized persons. In that line, set permissions to ‘read & write’. Click on the lock to close it, then close the Info panel.

Launch the DEVONthink application and open the database. Can you edit files? If not, Close the database and select it once more in the Finder. Open the Info panel. You should now be able to rename it by removing the suffix ‘.dtBase2’. If so, you should be able to follow Christian’s directions to apply the Sharing & Permissions ‘read & write’ permissions to the contents of the folder. To do that, click on the Lock icon, enter your administrative password, then click on the cogwheel symbol and apply the permissions to the contents of the folder.

Just enable the Finder’s preference to always show the extension and then it should be possible.

Thank you both very much for the assistance, I really like your product. I was never able to change the permissions and get it to work. I think I would need to use terminal to change because there are custom permissions carried over from prior system. However, I was able to export the data then import into a new database and it works fine.
Bill