Database open simultaneously in DTTG3 and DT3

Am I correct in thinking that this is now equivaIent to having a database open on two computers at once (i.e., bad)? I don’t think this was a problem in the earlier versions of DTTG, or maybe I just didn’t use it enough to encounter the problem. Thanks for any light you can shed.


Each device uses a local copy of the database. If you work on the same file on more than one device at any time then synchronising will lead to an error/duplication of the file.

You post doesn’t actually make it clear why you are asking - have you run into an error?

1 Like

Thanks for responding; sorry if I was unclear. I got a message on my laptop when I tried to access a database in DT3 saying that it was already open elsewhere. It was indeed open on my iPad. I knew that you couldn’t have a database open on two computers simultaneously; for some reason, it never occurred to me that it applied to my iOS devices as well, perhaps because I wasn’t using DTTG very much. DTTG3 is suiting my needs much better, and I am already using it more. Now that I know that you can’t have the database open on any two devices, I won’t make that mistake again.

You can have the database open on separate devices. As @Blanc noted, each device has its own local copy.

What you can’t do is open the same database file, e.g., if you had the .dtBase2 file on an NAS thinking you could open it from two machines.

I’m sorry to be stupid, but now I’m more confused than ever. I have DT3 on my desktop and my laptop, and DTTG3 on iPad and iPhone. All are syncing automatically on open and close through a sync store in Dropbox. I tried to save a PDF to DT3 on the laptop, and got a notice saying that the database was already open and did I really want to open a second copy knowing that it might be destructive. I’m familiar with this notification, having been using versions of DT for a long time, so I said no, don’t open it. I was trying to figure out why I had gotten the notification, and I thought it was because I had DTTG open on my iPad. If it’s ot because of that, then I’m at a loss, and would appreciate any light that you can shed.

Maybe on the laptop where you report seeing the notice, DEVONthink didn’t get closed down completely before computer shutdown or something like that. Nothing to do with completely separate instances of DEVONthink database on other devices (assuming they are not directly accessing the laptop’s database file… which is fraught with risk, of course).

For some reason or another the laptop’s operating system controlling the application you are using to “save” the PDF is controlling the need to open a second instance of DEVONthink database and that’s a mystery.

Exactly what app are you using on that PDF? Finder? Exactly how are you trying to saving into DEVONthink? (There are so many ways to do it).

At this point, I’d suggest doing a Verify and Repair of all your databases on the laptop.

Completely shutdown everything and do a fresh boot-up?

Also Best practice is to start DEVONthink manually (not part of the login script) and when doing a laptop shutdown, close DEVONthink before before starting the shutdown. I don’t know if it helps or not, but I usually close DEVONthink before allowing machine to “sleep”.

It wasn’t. It’s possible that when you previously closed the database on your Mac it wasn’t properly closed (edit: as @rmschne wrote before me, sorry I didn’t read that when doing a quick response), so on opening it got the message you quote. The message is only relevant if you are actually accessing that database multiple times - e.g. if you hat DT installed on you Mac in two different versions and opened both, or if you had put the database file on a server and were opening the same file from various locations (not the default behaviour and not recommended). For any “normal” user the message can be “ignored” (ie you can open the database, and it will automatically be checked for consistency).

@rmschne and @Blanc are correct on this: The message in DEVONthink is unrelated to anything happening in DEVONthink To Go.

And yes, you should press Continue to open the database. I’d suggest you do a File > Verify & Repair after opening it too.

Worse and worse: each time I open the database, being sure that it’s not open elsewhere, I get the notice that says it IS open elsewhere. I press Continue and it will open. However, I tried Verify & Repair. There was only 1 error noted in the verification: an orphaned file. But I tried Repair, and it crashed the program three times in a row. The next time, I tried Ignore, and it stayed open and so did the database in question. But according to the log, it is still trying every two minutes, and every two minutes the same message appears in the log: “Failed database verification, please repair the database.” I can’t afford to lose this database; do I need to start migrating stuff to a new one? :scream:

I would suggest you open a support ticket (in DT3 menu, whilst pressing the Option key on your keyboard, open the help menu and select Report Bug); the database should not be showing open if it is properly closed, and crashes should not be occurring at all.