Database package contents duplicates?


I noted today that when I inspect any of my database package contents there appear to be duplicates in the .dtMeta files. For every .dtMeta file there is a corresponding .dtMeta~ file of the same size (some have different time stamp). Is this to be expected?
Thank you.


Do you use ChronoSync and, and if so do you have “Dissect Packages” set? It appears that some process on your machine is duplicating internal files in the database package – (making files “abc” and “abc~”) – ChronoSync can do that, which is undesirable.

Try Tools > Rebuild Database… if you are having database problems.

Thanks for the suggestion, but I don’t use Chronosync. I tried rebuilding a database but those duplicate files remain. Would it be safe to delete them?


This is best diagnosed and fixed offline with direct assistance from Support.

I’ve encountered the same thing recently and I do not use Chronosync either-curious.

I’ve just checked my databases and see no duplicates in the metadata files inside the database. I’m running DEVONthink Pro Office under OS X 10.9, and have been working a couple of the databases pretty hard.

For backups I use Time Machine and Database Archives.

I suggest opening a Support ticket. Attach any recent DEVONthink crash report and provide information about the database(s) that exhibit duplicate metadata files from their Database Properties panel, including the size in total words. Also information about the Mac, including CPU, installed RAM and available free disk space. Do all databases showing duplicate metadata files report no errors when Tools > Verify & Repair is run?

Thanks everyone - I’ll open a support ticket. Interestingly, I haven’t been having any issues at all. I’m running 10.8.5 on both a mbp and mini and I sync using Dropbox (databases stored in respective ~/Documents folder). The dtMeta~ files show up on both computers. It was just an incidental finding when I was looking around my hard drive, and the only reason it now bugs me is that I have a couple of databases that are gigabytes in size and it seems I could save half of that space if I could delete those unnecessary files.

P.S. No errors are reported when I run Verify and Repair.