Database Password Parameters?

Forgive me if this is codified somewhere. Searches of the Board and Manual yielded no results…

Are there limitations for a database password as to 1) the number of characters in the password, or 2) any specific characters within it (e.g., \ / | ` ~ ^ . , %?) ?

A recent change in the password field of a database (aimed at strengthening security) has yielded an “Invalid encryption key” error message upon sync.

I want to eliminate the possibility that I have introduced an invalid password into the field by breaking a rule.

Thanks for your help.


You need to do clean the Sync location by right-clicking on the Sync Location in DEVONthink’s ​Preferences > Sync​, and selecting Clean Location from the menu. This will clear out the Sync Data currently in that location and you will have to reSync. This is because we cannot apply encryption to the files in that Sync location. Sync has to retransmit the Sync data, encrypting it as it is sent.​

Thank you. This works great on the Macs. Back in business. Not on the iPhone, however. DTTG still returns the Invalid Encryption Key error message.

So I went for a clean install on the phone.

I deleted the last beta build. (I was a beta tester for DTTG.) But there was no new beta version to replace it.

So I downloaded the current version production version from the App Store.

Same error message. I have confirmed that the password is correct.


Thank you!


Please start a Support Ticket. Thanks

Hi, I’m having a “3:10:58 PM: dtpostore.dtCloud Invalid encryption key.” error message on my iMac DTOP. I tried the clean steps above but this didn’t seem to work and I the app asked for Encryption. Not sure what this refers to. Are there more instructions? I’m using Dropbox and the iphone app hasn’t worked, synced, for me. It used to.


Please start a Support Ticket. Thanks.

I didn’t change any of my encryption passcode, however my DTTG started giving “Encryption key not available” for my Dropbox sync locations with no known cause. The timing did coincide with me updating DTPO on my Mac to 2.9.12 though.

@efndc: Just edit the Sync location, reenter the encryption key, the Save the location again.