Database Properties: Reported size includes full size of indexed files

Hi, Congrats on the new DT3. I’ve been using DTPO for several years now and really liking the upgrade. Thanks too for the 3.1 upgrade including the ability to move the tags and inboxes back within the databases. (The message for the upgrade came minutes after I’d used the hidden terminal workaround to reverse the behaviour.) It makes a lot more sense to me to have it that way. I’ll have to explore the alternative to see if that workflow makes any sense.

I’ve experimented with indexing a folder of videos on an external drive. This USB drive is permanently connected to my MacMini and contains all my multimedia, which then syncs every night to the NAS for backup.

I noticed when I brought up the Database properties that the database had increased in size by 43GB on top of the original 4GB or so prior to the indexing. I’m wondering if this is designed intentionally to work that way and why it would be?

I tested that the videos hadn’t been imported (they have the icon to the right indicating they are indexed) by ejecting the drive. The videos remain listed with all info including a preview pic visible and a message stating “Volume not mounted”. BUT, the size of the database remains at 43GB. This is the actual size of the folder on the external drive. I’m assuming (I hope correctly) that this won’t be the actual size of the database but the database PLUS the size of the videos folder. I would expect that there would be a small increase to size within the database for previews, metadata info etc but not the full size of the attached folder.
This could become confusing to some users (me) for instance if you need to work out the size that a database will consume on other hardware, iPads, iPhone for instance.

Maybe the database properties window needs a Size (actual): and another line Size including indexed data: ?

Anyone else experienced this?

Database Properties shows the size of the content, indexed or not.
That is a distinct value from the database’s size in the filesystem.

Aha, (Lightbulb Moment) so I can use Show in Finder to see the actual disk size!

I got it.

Great, Thanks Jim @BLUEFROG I can work with that.

You’re welcome :slight_smile:

Further to the discussion on reported database size and size on disk I’m in the process of noticing a disturbing “issue”, IMHO.
I have indexed a library of videos to a database, said video library is ~ 225GB (difference between database size and size on disk). The problem is that when I sync this database to my other Mac via dropbox it is syncing the entire library of videos not just the indexed information. This isn’t the behaviour I expected, nor want. I wanted to see the names of videos/ podcasts etc in the synced version so I could search the database and then go watch the video from Plex. I don’t need to watch it from within Devonthink.
If this is the expected behaviour it makes indexing useless to me if I wish to sync this database, especially once I sync with my iOS devices. The videos are stored on the NAS and I don’t wish them to use up space on Dropbox or particularly on my Macs either.

The only option I can see is to keep the indexed video files in their own database and don’t sync them.

Any one else noticed this behaviour?

Oh, the reason I haven’t been able to prove this yet is that its still uploading to dropbox (I only have 5Mb upload speed) after almost 2 days, so I should know for sure by tomorrow if these synced folders end up on the other Mac. :slight_smile:

From the user manual (also available in app):

In the Show Info for a sync location in Preferences > Sync there is an option Synchronize contents of indexed items. Unchecking this will sync only the metadata for the files, not the contents.

However, do please read the relevant section of the manual (Indexing and sync) as there are warnings about use of that preference.


1 Like

Yes, as @Stephen_C mentioned this is the expected behavior. The contents of indexed items is synchronized by default.

And as he also pointed out :slight_smile:

From Documentation > In & Out > Sync

Thanks guys,

yep should have read the manual.


You’re welcome :slight_smile: