Databases not showing in iCloud

I recently got a new iPhone and DTTG has not been working on it properly since the new phone was set up. I separately run DTTG on the iPad and it works perfectly. The files are synced using Devonthink 3 over icloud.

On DTTG on the iPhone, when selecting settings>locations>iCloud, all that shows is Global Inbox, and none of my databases. And even if I try and synchronise Global Inbox, I get an error log that says that “can’t create folder of database “global inbox”, path exists already”.

Following a tip in another thread, on my Mac I went into the iCloud settings to delete the devonthink data in iCloud. Thereafter Devonthink freshly uploaded all databases to iCloud.

As I mentioned previously, DTTG working perfectly on the iPad.

Please assist.

Many thanks,
Ilan

1 Like

Which version of DEVONthink and DEVONthink To Go do you use? The latest ones (3.0.3 and 2.7.6)?

Yes, the latest ones that you have shown.

And which version of iOS/macOS do you use? Did or do you use any public betas of them?

Mojave, and iOS 13.2.3. I have not used beta versions of any of the OS’s.

Depending on the size of the databases it might require some time until all required files will be available on iOS (due to the asynchronous iCloud sync). By the way, is there enough space available on the iPhone?

Hi. I recently developed a similar issue. I have one database that contains roughly 400 .pdf’s (just started using DT). I set up DTTG on my iPad and iPhone (all three running most recent version, DT on Mac is trial while fitting this into my workflow).

Had a .pdf that wasn’t syncing. Tried multiple different solutions. Deleted file, re input into DT. No luck.

Then tried cleaning sync store on Mac. No luck. Have spent the last several hours searching these forums, looking for solutions. Deleted the iCloud cache as mentioned above. No luck. Deleted and re-installed DTTG. No luck. And now, on DTTG, I cannot see any databases other than my Global Inbox.

All devices have plenty of space, and the database size is about 170 MB. Fast connection on both ends of my workflow.

Any suggestions would be greatly appreciated. Thank you very much.

As an update, I created a new database on my iPhone, and it synced back to my Mac. However, when I dropped a .pdf into that new database, it would not show up on my iPhone. Very strange.

And one more. Tried local sync over Bonjour, and the personal database that I have on my Mac did NOT show up as an option to sync to my iPhone, just the Global Inbox. It is as if nothing by my Mac is recognizing my database.

It is quite possible iCloud has stalled - a condition over which we have no control, nor can we even detect it. We can’t reproduce this issue, and some have said it “just started working!”

Here are a few things people have said “worked” , though we obviously can’t test it since we can’t reproduce it. I would try them individually…

  • Reboot the problematic device(s).
  • In DEVONthink’s Preferences > Sync, disable the iCloud location and quit the application. Relaunch DEVONthink and re-enable the sync location again.
  • In iOS’ Settings > your Apple ID > iCloud, try disabling and re-enabling iCloud Drive and DEVONthink.

Thank you. I had come across those steps previously during my search, and tried them all. The behavior that I am encountering seems somewhat strange. I was able to get my local database re-uploaded to my iPad/iPhone by creating a dropbox sync, allowing that to do a full sync, and then re-syncing through iCloud. What is happening now is as follows:

  1. When I make an edit/highlight/comment on a .pdf in DTTG, it is readily and quickly synced with DT on my Mac
  2. When I add a new document on DTTG, it is readily and quickly synced with DT on my Mac
  3. When I add a new document to DT on my Mac, it does not get synced to DTTG through iCloud
  4. When I make an edit/highlight/comment on a .pdf in DT on my Mac, it does not get synced to DTTG through iCloud

I don’t quite understand where the problem lies. I have cleaned and rebuilt my local databases, and taken all of the steps listed above (including deleting and re-installing DTTG countless times, rebooting iPad, etc.) Thank you for your help and the great software.

You’re welcome.

You rebooted the Mac?

I’m curious, why you’re not just using Dropbox instead since you used it for syncing already.

I have not rebooted the Mac. Will try that now.

I’m already paying for an iCloud family plan and trying to get off of Dropbox. I’m really liking DT during the trial and would not want to have to pay for a separate platform just for syncing.

Rebooted Mac. Mac side of things (DT) still not getting to DTTG through iCloud. sigh.

Are you able to successfully verify the sync store (see contextual menu in Preferences > Sync)? And are any issues logged on the Mac (see Windows > Log) or on iOS?

Yes. I was able to verify the sync store thoroughly, both on the Mac and on iOS. No issues logged on either side.

I kinda gave up for now, as I have some deadlines to meet and just switched to Dropbox sync for now. Will try again once the work is done.