Databases not syncing in 2.7.1


Using DT 2.7.1 and datyabase sync is not working. It HAS worked in the past. but not its just stopped. I click Syncrhonise and goes through the various statuses as if nothing has changed, but I have changed it, new files are not being sync’d to another computer. If I add a new file on both my Macs, the other Mac does not get the new file on the other one. So looks like changes are not being pushed to the Webdav.

if I have to delete the DB and create a new one, and sync again, then please tell me how to delete the database from the Webdav, because i had this issue a while back in 2.5 and the solution was to delete the database, start again, but the dB on the Webdav would still be there, I cant tell which one it is to delete it, I dont want unused DBs hanging around taking up space on my Webdav.


When you upgraded to 2.7.1, did you clean your syncStores? (I’m guessing not.) This needs to be done, and also answers your question about how to delete the old stores.

In Preferences > Sync, select the database to delete from the store, click the Action button (gear icon) and choose “Clean Location…”.

When I do this it says:
“All records in the remote copy of the database will be removed.”

So does that mean it will sync to the remote again? Send all files to it?

What does this mean when you have different changes in two Macs? Meaning if it deletes the remote sync and then pushes the database again from my computer, when I go to my other machine, will it see the differences on that machine and sync them, or will it download the remote sync, wiping out the differences on the second machine?

Hope you know what I mean, its just I thought this has been syncing properly, so my databases on both machines are now different.

Following this thread, I will take a guess its OK to clean the database, it does not wipe data, and its OK to do the sync on the other computer following a clean and sync on this computer.

So I cleaned the remote, and now it is syncing from my macbook to the remote, which it did not earlier. Tomorrow I will then try syncing from my work machine again. If you dont hear from me… its worked :slight_smile:

Yeah, it just cleans the old Sync data that’s shared between machines so it only needs to be done by one machine.

Its not working still sorry… well half working maybe

I cleaned the remote database, it deleted some files
Then I syned again, and it uploaded new files

On the other computer, when I then synced, and it is stuck on “Fetching Remote Records”

This is the same with 2 databases I am using.

I’m also getting stuck on “Committing remote transaction too”

At the moment, all my databases are not syncing, they get stuck on either fetching or committing

  1. Don’t have the second machine do anything until the store is cleaned and the first machine is Synced.

  2. if you have upgraded both machines, reboot them both before Syncing.

Also, remember - if you are using a Dropbox Sync, your network plays a large part of the speed of the Sync. Your connection is not a constant stream of data and can be throttled by various issues. If this is a multi-gigabyte database… be patient.

I have rebooted the machine several times since upgrading, and am not using Dropbox.

I will try again by rebooting, cleaning the store on one machine, syncing on that same machine, then when thats complete, sync on the other machine. But am sure I this.


Have seen quote a few bugs on Mavericks, wonder if its related. Cant even quit Devonthink on my iMac… just sites there, its responding OK. Will have to force quit. Wonder if thats related too.

Is this a new machine with a Mavericks install, or an upgrade to Mavericks from Mountain Lion?

Sorry still has issues…

I restarted the Macbook, then cleaned the sync store, then synced. One database completed OK, the next one started to send the files to the sync store. About 1/10th way in on the progress tab it just stops. I thought it completed. But a restart, then a new sync. starts the sync over again and the same thing happens.

When go and sync the first DB again, the one that worked earlier, it hung on the Sync -> store statement at the top, with no status below it. But thats working now cant repeat it.

Syncing the second database again, hangs on Fetching remote records. So I close Devonthink, reopen, clean the sync store, sync again, and it starts pushing the files to the sync store, then 1/10th through it finishes like before, and wont sync again.

If I sync this same database on my other machine I get the same issue, starts to send all files, finishes 1/10th way through progress, and does not sync again.

So I just cant sync the database, there are various errors that occur. Maybe its an issue with the store as both machines have issues.

For info, my sync store is on a WebDav drive that is located in the office here on the same LAN as my Macbook and iMac.

Please start a Support Ticket.

Try the Sync operation again AFTER following these instructions…

To enable logging, type the following in /Applications/Utilities/ and restart DEVONthink:

defaults write com.devon-technologies.thinkpro2 DTSyncDebug -bool YES
defaults write com.devon-technologies.thinkpro2 DTSyncDebugHigh -bool YES

This will log more detail to your system log, which can be viewed in /Applications/Utilities/

After you’ve attempted the Sync…

  1. Open and type “DEVONthink” in the searchField in the upper right-hand corner.
  2. Click in the results and press Command-A to Select All.
  3. Select File > Save Selection As… and save the results to a text file named “DT Sync.log” on your Desktop.
  4. Attach the document to your Ticket.

Ok will do that.

At the end of cleaning it just says “committing remote transaction” for ages, but in console it shows loads of errors like this:

30/10/2013 12:04:31.507 DEVONthink Pro[1899]: Encountered connection error -1001 (error Error Domain=NSURLErrorDomain Code=-1001 “The request timed out.” UserInfo=0xxxxxxxxxx {NSUnderlyingError=0xxxxxxxxxx “The request timed out.”, NSErrorFailingURLStringKey=http://xxxxxxxxxxxxx, NSErrorFailingURLKey=http://xxxxxxxxxxxxx, NSLocalizedDescription=The request timed out.}) with connection <NSURLConnection: 0xxxxxxxxx> { request: <NSMutableURLRequest xxxxxxxxxxxxx> }

(the xxxxx was a path to a file of the following format, I changed as I dont know if its private info or not:

Do you think there is an issue with my Dav server? It works at first, but then connection drops/timesout?

What i would expect to see are errors output to the sync status window, it is a bit long winded finding these errors this way.

Sure sounds like it. Is this your WebDAV server and setup or some provider’s, ie. not on your LAN?

Its my own WebDav server in my office as I have many many GBs in several databases (the ones in question are 800Gb and 1.2Gb). Its been working like this for a long time though, I use the server for other activites like backups. But DT does connect initially, and processes some tasks, its only half way through or toward the end this happens. And it never used to.

I am considering using a Webdav I have on an Amazon EC2 instance, but would prefer to get to the bottom of this.


One of my databases has now synced with Amazon EC2.

BUT my other one is not. It wont clean the store, and it wont sync. The status bar just closes. So if I choose to Clean it the status bar pops up and never gets to the message about deleting files it just closes at Beginning Remote Transaction. If I choose sync it gets to Beginning Remote Transaction then it just closes. Tools -> Verify & Repair did nothing. So I do not know how to fix this one.

There’s errors like this in console (I replaced lots of random characters with xxxx):

Write Data xxxxxxxxx-xxxx-4DF2-xxxx-xxxxxxxxx.lockfile Error: Error Domain=com.devon-technologies.DEVONthink.Sync.HTTP Code=403 “forbidden” UserInfo=0xxxxxxxxx {URL=http://mywebdavURL/Devonthink.dtSyncStore/xxxxxxxxx.lockfile, NSLocalizedDescription=forbidden, Method=PUT}

Do you think this forbidden message is the reason? If so, what does forbidden mean?

Another couple of databases I have just successfully synced with this webdav OK.

I logged into my server and the lockfile was owned by root. Have no idea how, maybe from ages ago I used root to connect initially. So changed owner to apache like the rest and now its working OK.

I honestly think DT should be giving us these error messages, and not have to turn console on etc. its very long winded.

Does Menu > Window > Log not say the error?