Default Database in DTPO 2.0b2 doesn't work

Whenever I set a database as the default in v.2.0, the next time I open DTPO I see no databases at all (I have four) and then can’t get them to open by any other means, such as double-clicking on the database files, selecting ‘Open Recent’ or ‘Open Database’ menus, or by choosing ‘New Window’.

The only workaround I have found is to quit, open DTPO 1.5.4, then open any old database, quit 1.5.4, open 2.0 (which never fails then to start up without a database window regardless of preferences), and finally to select the database I want using the Finder.

Anyone having similar problems, or able to suggest a solution?

Sounds strange.

IN DTPO2 Preferences > General - Startup: Make sure you have checked “Open windows that were open on quit” and also set a default database. (If “Do nothing” was checked for General - Startup preferences, you won’t see anything on launch even though a database is open.)

Thanks, Bill. Already tried that several times. No go.

Then it’s probably time to do some trouble-shooting on your computer. Something is amiss. OS X maintenance? Some weird “hack” software recently installed?

Good thought, Bill, but sad to say no new software, no hacks.

Maintenance is up to date (daily, weekly, monthly) – in fact, after I first noticed the behaviour, I ran through the whole maintenance schedule, cleared caches manually and trashed preferences.

It’s been like this since I installed v.2.0b2, and yet 1.5.4 runs as normal. I might have missed something, but I can’t think what it might be.

No further thoughts, Bill?

Anyone?

Frankly I’m stumped as to why I can select a v.1 database in the Finder and have it open in DTPO 1.5.4 as normal, but when I do the same thing with a v.2 database, DTPO 2.0b2 starts up, but displays no databases at all (despite preference settings to the contrary).

Is there no-one else experiencing something similar? All contributions welcome.

IW

I have similar issue here (I’m using DT Pro 2.0b2). I can’t set a default database even I ticked the “open windows that were open on quit”. What make things worse is that, if I dropped something into the default inbox of sorter before starting DT, and then launch DT, the content in inbox will be lost because of no default database and global inbox (not implemented yet).

Also the archive bookmarklet won’t work if DT is not running due to similar reasons…

A database is set as the default either by choosing it as default in Preferences, or by checking it as default in File > Database Properties.

As noted in the Upgrader’s Guide, the Global Inbox isn’t activated in public beta 2, and shouldn’t be used. However, anything that was dropped into the Global Inbox isn’t lost. That material can be found at ~/Library/Application Support/DEVONthink Pro 2/Inbox/. If you leave it there, it will be sent to the Global Inbox when that feature is activated in a future release. If you wish, you may move it to a database before that.

Although the Global Inbox isn’t yet activated, you may add the Inbox or a group from your database(s) to an open slot in the Sorter. That will work whether or not DEVONthink is running, or the target database is open.

Mmm. I don’t seem to be getting very far towards a solution with this one, so let me ask the question this way:

Why would I be able to double-click a DTPO1 database in the Finder and have DTPO1.5.4 open and display the database as normal, but when I double-click a DTPO2 database in the Finder, DTPO2.0b2 starts up but doesn’t display the database?

All ideas welcome. Perhaps someone in the Devon team has an idea because of changes made in the new version?

IW

Just guessing here, but perhaps it is related to having both versions of DTPO still on your system. Keeping the older version can cause some issues, especially with the Services menu commands, so it might be worthwhile to archive 1.5.4, reboot, and see if the problem persists. FWIW, I can double-click on DTPO 2 databases in the Finder and they open and display as expected.

Thanks for the suggestion, Greg, but still no go.

IW

You said that when you double-click on a DT Pro/Office 2 database, the application launches but you can’ t see a database?

What happens if you choose File > New Window?

Tried that, Bill, nothing. As I mentioned in my original post, I have tried numerous workarounds/repairs/restarts to avoid having always to (1) open DTPO2 empty and (2) then select a database from the Finder (bearing in mind that doing it in reverse order or nominating a default database achieves nothing.)

DTPO2 is the only application I have that behaves like this.

IW

And yours is the only installation of DTPO2 I’m aware of, in which double-clicking on a database won’t open it, or the application can be launched without opening a properly designated default database.

Have you tried a new user account, which could be used to see if you have an extension installed in your current user account that is causing the problem?

Bill, I tried your suggestion with two other user accounts, but with the same result.

Did I understand you correctly: DTPO should not be able to open at all unless there is a designated default database?

No, Bill is saying that if a database has been designated as the default, DTPO should not launch without also opening the database.

A couple of other suggestions-have you performed a ‘Get info’ on the database file in the Finder and confirmed that a) you have read/write permissions and b) DTPO 2 is the default application to open the database?

Have you tried opening DTPO and then dragging the database file on to the DTPO icon in the dock?

Thanks, Greg. Already tried the Get Info approach.

Any ideas though, Bill, on why DTPO1.5.4 would open on a database file by double-clicking on it, but DTPO2 won’t?

IW

There seems to be something eccentric about your computer.

  1. With DTPO2 Quit, try deleting the preferences (except for registration, if any) at ~/Library/Preferences/. The .plist files will start with “com.devon…” – choose those for DT Pro 2. Then relaunch DTPO2. You will need to reenter any preferences you had set. Launch DTPO2. Open a database and use File > Database Properties to make it default. Quit DTPO2. Launch it again. Does a database open?

  2. If that doesn’t work, check the possibility that a 3rd party extension may be frakking up things. Shut down your computer and wait ten seconds. Startup the computer, holding down the Shift key until it has booted up. This is Safe Mode. The boot will take a bit longer than normal, as your computer is running some diagnostic routines.

Launch DTPO2. Does it open with a database? If so, that’s an indication that you should look with suspicion at some of the software utilities that are on your computer.

Thanks for the suggestions, Bill. I tried both with no luck.

However, I did notice that although DTPO2 doesn’t display the default database, it clearly thinks it has opened it and displayed it. If I go to File > Database Properties, all the file properties are there as if it were open/displayed. Selecting New Window at this stage produces nothing. Trying to open another database likewise. This behaviour is consistent whether I boot normally or boot into Safe Mode, before and after trashing preferences.

Eccentric or not, my computer (PBG4, 1.5GHz, 2GB RAM) is getting long in the tooth, though I’m sure there are other users with similar configurations, so I really can’t see age being a factor. Time for coffee, followed by more head scratching.

Thanks again for your help.