Default.Sorter and file permission problems

As there seems to have been a previous report of this problem:

and as I have not had any other file permission problems, I think it might be interesting to report the following message arising from using the Sorter, which I have only just begun to use …

Switching off the sorter, deleting Default.Sorter, and starting again, leads to a repeat of the problem, and the same pattern of permissions.

Like the previous user, I think that perhaps I will avoid the Sorter for now :slight_smile:

Yes, this is a known problem with dropping folders on the Sorter and has been fixed for the upcoming update. For the time being, don’t drop folders on the Sorter.

I take it that that includes bundles - such as, for example, most OmniOutliner files.


Hello everyone,

I am experiencing this problem. Every time I start DevonThink and the sorter, it prompts me: “The document ‘Default.sorter’ could not be saved.”

I am fairly new to DevonThink, so I have no idea how to solve this. The prompting won’t stop, resulting in an effective freeze of the whole software.

MBP 2017, fresh OS installation, recently updated to High Sierra, fresh DevonThink installation.

maybe another interesting point in this matter:
First, everything worked fine. I then tried to add larger amounts of files to the sorter. I added them and the sorter became unusable. I waited two hours but it seemed like it froze. I killed it. Restarted the whole thing and the error appeared. My uninformed guess is, that the sorter still blocks the file but neither do I know how to find that file nor how to proceed.

any help much appreciated

Please define “larger amounts”.

  1. In DEVONthink, select Tools > Hide Sorter.
  2. Quit DEVONthink.
  3. In the Finder, press Command-Shift-G and paste: ~/Library/Application Support/DEVONthink Sorter/Default.sorter . Move this file to your Desktop.
  4. Launch DEVONthink and select Tools > Show Sorter.

If this does not work then follow the same steps outlined above but do this for item 3…

  1. Open Applications/Utilities/ and paste: defaults delete com.devon-technologies.think-sorter . Press Return.
  2. Then type: exit , press Return, and quit Terminal.

Thank you for your quick response.

larger amounts of data in my sense are:
I remember something like 10 GB and a few thousand files.
My Inbox.dtBase2 is 14.34 GB right now.

The first 4 steps do resolve the prompting but as soon as I add anything, the software freezes again.
My /Library/Application Support/DEVONthink Sorter/Global Inbox seems to catch all the files as intended and now covers 25.93 GB. But the software freezes and does not show anything.

I removed everything, i.e. the 14.34 GB and the 25.93 GB. Now it seems to be working. Thanks for your directions – I would not have been able to do this without them.

On a related but different track:
I am testing DT Pro Office with its 150 hours free. I am now at 37 hours left but so far were only able to use approx. 8 hours effectively for my work. Is there any way for me to use the full trial time again?

thanks and best regards,

Sorry, but no, you can’t recover the time. However, you can request a trial extension via Help ? Support Assistant. Cheers!