DEVONthink 3.8 - WikiLinks can be converted to item links - How?

From release notes

As linking becomes increasingly commonplace, WikiLinks can now be converted to more “stable” item links.



See menu Tools > Item Links


1 Like

Maybe a silly question, but I will ask anyway. How do we know that the wikilink was converted to item link?

What I ask myself when I read the release notes is what does that mean for my daily work?

Wikilinks are implemented very practically in DT with the function of automatic detection. This does not work with item links. If I convert the wikilinks to item links now, I would have to do this regularly, since new wikilinks may be added to the documents, right?

Does that also mean that the chance of wiki links in DTTG has decreased because the more stable item links are used?

It’s just a personal preference whether you use WikiLinks or item links. Item links are of course more persistent and do not break e.g. after renaming. And now you have the opportunity to create them semi-automatically.


E.g. disable Format > Wiki Linking temporarily.

Christian – Thanks. I did. It worked for Markdown but not for RTF. In Markdown, the file’s name had to be fixed because DT added “/” in names separated by spaces. I will keep testing.

What exactly did you? Additional details would be highly appreciated.

I created a markdown text with one wiki link. Then, I used the new tool to convert the wikilink to item link. Everything worked as expected.

After then, I created an RTF file with a wikilink and used the new tool to convert the wikilink to an item link. Then, I went to preferences and disabled wikilinks as you suggested. To my surprise, when I rechecked the file, the item link was not there.

What kind of Wiki link did you use? There are multiple possibilities (see Preferences > WikiLinks). In addition, Wiki links support also items which do not yet exist but item links require existing items.

I linked to an existing item and used the “name and aliases” option.

I can’t reproduce this so far, which name did you use?

In my RTF note (testing 1), I added a wikilink to an item named “Testing Item Link” and to another item named “TestingItemLink.” No item link was showed after I used the tool and disabled the Wikilinks in the Preferences.

I linked the same two items to the same RTF note using the Insert>Item Link> to complement my test. The result: everything worked well.

This seems to be a bug in case of rich text documents and using the option Names & Aliases. We’ll check this, thanks.

Fixed for the next release.


Thanks Christian. I am happy that I could help!

1 Like