Devonthink and Devonagent - neither will start

All has been well for more than a year. Suddenly, for no reason that I can see, neither program will even start. I get the bouncing icon in the dock for a few seconds and then it just stops. I have tried a number of solutions that I found on here:

  1. reinstalled
  2. deleted plist files
  3. used a backup copy from a time that I know it was working
  4. repaired disk permissions

and nothing. I simply cannot get either program to start. Obviously I really need to get in there - my entire business world is trapped inside!

Anything I haven’t tried yet?

Paul

Hi, Paul. As you can’t get either application to launch, is that true for any other applications as well?

Try launching Applications > Utility > Activity Monitor. There’s a series of tabs in the bottom half of the window: CPU | System Memory | Disk Activity | Disk Usage | Network.

Click on CPU usage. If your computer is idle, CPU activity is low. If it is very high, that’s an indication that a rogue process or stalled application is using up your CPU resources. You can identify and force quit any misbehaving process in Activity Monitor.

Click on System Memory. If free RAM is low and there are many pageouts, you are working in Virtual Memory and the computer will likely be slow. Even something as simple as a restart may speed everything up.

Click on Disk Usage: Apple engineers recommend at least 15% of your disk space should be free for use by the operating system and temporary files required by many applications. If you are out of disk space, everything will be slow, and there’s a possibility that files could be overwritten and damaged. Housekeeping to free up disk space would be in order. (Sometimes huge log or cache files can fill a drive; AppleJack or OnyX can clean those up.)

As your computer is behaving abnormally, I would suggest running some operating system routines such as those in AppleJack or OnyX. Both are free and can be found if you search Google for them.

tried all of the above and no luck – all other apps open fine – and I’m running pretty barebones with all external utilities turned off.

What do you mean by “external utilities”? If you have haxies, for example, there will be residual effects in the OS pending a restart and reloading of the OS.

nothing major - just DragThing and Quicksilver. both have been running fine along with DTP for months

Did you do OS maintenance including cache cleaning, etc. using something like the utilities I mentioned (there are others that can do similar routines, or they can be run from Terminal).

How are you launching DEVONagent and DT Pro? Are you clicking on Dock icons that were created by an older version, and perhaps after setting a different location in your Applications folder for the new versions? (Try double-clicking in the Finder on the new versions of the applications.)

If not, there’s definitely something amiss on your computer.

QuickSilver shouldn’t be a problem, and I haven’t heard of problems involving DragThing.

Paul,

please check if anything is logged to the system console (see /Applications/Utilities/Console.app) while trying to launch DA/DT. In addition, please check if there’s a crash log in the folder ~/Library/Logs/CrashReporter. Thanks.

I never even knew that console program existed. When I tried to start DT or DA, a utility that I had forgotten about (newly installed, oops) called STOPLIGHT was loading. When I added the devon brothers to the exclude list, it loaded fine.

thanks again,
Paul

Stoplight is a really poor input manager - I can’t recommend its usage at all.